Bug 201744 - [71cat] Unable to open after enabling Web Projects
[71cat] Unable to open after enabling Web Projects
Status: RESOLVED WORKSFORME
Product: platform
Classification: Unclassified
Component: Module System
7.1
PC Windows 7
: P2 (vote)
: TBD
Assigned To: Jaroslav Tulach
issues@platform
: ERGONOMICS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-07 13:18 UTC by javydreamercsw
Modified: 2011-09-13 11:08 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
logs (84.42 KB, application/octet-stream)
2011-09-07 13:19 UTC, javydreamercsw
Details
Logs when Web project was enabled (81.87 KB, application/octet-stream)
2011-09-07 13:19 UTC, javydreamercsw
Details

Note You need to log in before you can comment on or make changes to this bug.
Description javydreamercsw 2011-09-07 13:18:24 UTC
[ BUILD # : 201109060060 ]
[ JDK VERSION : 1.7 ]

I was retrying to work with a web project that works perfectly on 7.0.1. So I
opened the project and it went to enable the Web module. When it was done it
complained about 131 modules missing a dependency (Editor 2). So I went ahead
and updated. Restarting the IDE is useless. It crashes on the process.
Comment 1 javydreamercsw 2011-09-07 13:19:02 UTC
Created attachment 110471 [details]
logs
Comment 2 javydreamercsw 2011-09-07 13:19:53 UTC
Created attachment 110472 [details]
Logs when Web project was enabled
Comment 3 Jesse Glick 2011-09-07 22:16:34 UTC
Something got corrupted during module update or enablement, no clue what. Cannot even tell what is going on from the logs you attached, since even the second attachment - the earlier log - does not show a normal startup. Is there some way to reproduce this? Reassigning to module system since even bad configuration in config/Modules/*.xml ought not trigger an assertion in ModuleManager.maybeAddToEnableList like this.

Why is this filed in apisupport.project?

Not P1, just use a fresh NB installation.
Comment 4 javydreamercsw 2011-09-08 01:15:48 UTC
I'll try to reproduce it and attach steps.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo