Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 201628 - Not compilable code, problem with internationalization
Not compilable code, problem with internationalization
Status: RESOLVED DUPLICATE of bug 196497
Product: guibuilder
Classification: Unclassified
Component: Code
7.1
All All
: P4 (vote)
: 7.2
Assigned To: issues@guibuilder
issues@guibuilder
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-05 11:31 UTC by asenk
Modified: 2011-09-08 15:20 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description asenk 2011-09-05 11:31:24 UTC
Product Version: NetBeans IDE Dev (Build 201109040600)
Java: 1.7.0; Java HotSpot(TM) Client VM 21.0-b17
System: Linux version 2.6.38-11-generic running on i386; UTF-8; en_US (nb)

1. Start IDE with fresh userdir
2. Create new Project-> NetBeans Modules-> Module
3. Next
4. Type :org.something.name in Code Name Base
5. Finish
6. create new JPanel in org.something.name
7. Put JButton into JPanel

in initComponents() method is this incorrect line:

jButton1.setText(org.openide.util.NbBundle.getMessage(NewJPanel.class, "NewJPanel.jButton1.text"));
Comment 1 Jan Stola 2011-09-05 15:20:55 UTC
It seems to be a rather artificial issue. It can happen only in a very new NetBeans project that doesn't contain anything useful yet (because it doesn't have dependency on an extremely basic/common module org.openide.util). Even in the unlikely case of encoutering this issue it is absolutely clear to user what must be done to fix the mentioned problems, i.e., to add the dependency on org.openide.util => lowering priority.
Comment 2 Jan Stola 2011-09-08 15:20:01 UTC

*** This bug has been marked as a duplicate of bug 196497 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo