Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 201564 - Reformat for whole project
Reformat for whole project
Status: RESOLVED DUPLICATE of bug 67397
Product: editor
Classification: Unclassified
Component: Formatting & Indentation
6.x
All All
: P2 with 2 votes (vote)
: TBD
Assigned To: Dusan Balek
issues@editor
:
Depends on: 25377
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-02 12:17 UTC by Jan Lahoda
Modified: 2013-12-18 22:28 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Lahoda 2011-09-02 12:17:27 UTC
This is a spin-off of bug #25377. The request is to be able to reformat whole project/folder/package. Possibly for Format action itself could be extended to perform that?
Comment 1 roti 2013-01-10 11:54:44 UTC
Although the refactor/Organize Imports implemented in bug #25377, the "fix import" is still missing.
For example, when I have missing import(s) by a mass replace, I still have to fix imports manually on each file.
I know it is not obvious, when I have to choose from more imports, but it would be still a nice feature.
Comment 2 motin 2013-04-22 20:58:22 UTC
This plug-in supplies the requested functionality: http://plugins.netbeans.org/plugin/18365/format-files

Officially it is only for 6.9, but a community member (mcclosdl) has compiled a version for 7.1, which I recently verified works great also for 7.3 - check the comments on the plugin page!
Comment 3 markiewb 2013-12-18 22:28:55 UTC
Duplicates https://netbeans.org/bugzilla/show_bug.cgi?id=67397

Was fixed in 7.2. See also http://wiki.netbeans.org/NetBeans_72_NewAndNoteworthy#Reformat_Multiple_Sources

----
Although the refactor/Organize Imports implemented in bug #25377, the "fix import" is still missing.
For example, when I have missing import(s) by a mass replace, I still have to fix imports manually on each file.
I know it is not obvious, when I have to choose from more imports, but it would be still a nice feature.

-> "Fix import" for project/folder/package is a different issue. File a new one, but I guess there is already such one.

*** This bug has been marked as a duplicate of bug 67397 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo