Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 201474 - no autocomplete if multicatch
no autocomplete if multicatch
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Completion & Templates
7.0.1
All All
: P3 (vote)
: 7.1
Assigned To: Dusan Balek
issues@editor
:
: 200009 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-31 06:34 UTC by muellermi
Modified: 2011-11-16 16:41 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description muellermi 2011-08-31 06:34:45 UTC
Product Version = NetBeans IDE 7.0.1 (Build 201107282000)
Operating System = Windows XP version 5.1 running on x86
Java; VM; Vendor = 1.7.0
Runtime = Java HotSpot(TM) Client VM 21.0-b17

If one uses a multicach for a couple of exceptions, e.g.
            } catch (NoSuchFieldException | IllegalArgumentException | IllegalAccessException ex) {
                ex.
then after the dot, there is no sugesstion. It should display all methods and attributes which are common to these exceptions.
Comment 1 Dusan Balek 2011-09-02 08:18:25 UTC
Fixed in jet-main.

http://hg.netbeans.org/jet-main/rev/fed494c81a11
Comment 2 Quality Engineering 2011-09-03 14:27:14 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/fed494c81a11
User: Dusan Balek <dbalek@netbeans.org>
Log: Issue #201474: no autocomplete in multicatch - fixed.
Comment 3 Dusan Balek 2011-10-13 13:34:38 UTC
*** Bug 200009 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo