Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 201465 - AssertionError: Should be a folder: C:\Users\Mark\Documents\NetBeansProjects\FireFly\build\classes\com\areaofthoughts\fireListeners@f5a1befa:17ee7bc
AssertionError: Should be a folder: C:\Users\Mark\Documents\NetBeansProjects\...
Status: RESOLVED DUPLICATE of bug 202413
Product: platform
Classification: Unclassified
Component: Filesystems
7.0
All All
: P3 (vote)
: TBD
Assigned To: Jaroslav Tulach
issues@platform
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-31 02:47 UTC by MackSix
Modified: 2011-10-12 08:33 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (638 bytes, text/plain)
2011-08-31 02:47 UTC, MackSix
Details
Same error, different computer, OS and newer NetBeans Dev build. (44.77 KB, text/plain)
2011-10-03 01:46 UTC, MackSix
Details

Note You need to log in before you can comment on or make changes to this bug.
Description MackSix 2011-08-31 02:47:08 UTC
Build: NetBeans IDE Dev (Build 201108290601)
VM: Java HotSpot(TM) Client VM, 21.0-b17, Java(TM) SE Runtime Environment, 1.7.0-b147
OS: Windows Vista

User Comments:
MackSix: Opened a project and double clicked a java source file in the Porjects window to view it.




Stacktrace: 
java.lang.AssertionError: Should be a folder: C:\Users\Mark\Documents\NetBeansProjects\FireFly\build\classes\com\areaofthoughts\fireListeners@f5a1befa:17ee7bc
   at org.netbeans.modules.masterfs.watcher.Watcher$Ext.unregister(Watcher.java:247)
   at org.netbeans.modules.masterfs.watcher.Watcher.unregister(Watcher.java:130)
   at org.netbeans.modules.masterfs.filebasedfs.fileobjects.BaseFileObj.removeFileChangeListener(BaseFileObj.java:508)
   at org.openide.filesystems.FileUtil$Holder.run(FileUtil.java:554)
   at org.openide.util.lookup.implspi.ActiveQueue$Impl.run(ActiveQueue.java:109)
   at java.lang.Thread.run(Thread.java:722)
Comment 1 MackSix 2011-08-31 02:47:12 UTC
Created attachment 110290 [details]
stacktrace
Comment 2 MackSix 2011-09-28 21:07:30 UTC
Renaming Project and Package and trying to run the Project is giving the same AssertionError.

See http://statistics.netbeans.org/analytics/exception.do?id=528029
Comment 3 MackSix 2011-10-03 01:46:54 UTC
Created attachment 111409 [details]
Same error, different computer, OS and newer NetBeans Dev build.

Tried on different computer running XP & Newer NetBeans Dev Build. Same error occurred. See messages.log

Product Version: NetBeans IDE Dev (Build 201110020601)
Java: 1.7.0; Java HotSpot(TM) Client VM 21.0-b17
System: Windows XP version 5.1 running on x86; Cp1252; en_US (nb)
Comment 4 Jaroslav Tulach 2011-10-12 08:33:38 UTC

*** This bug has been marked as a duplicate of bug 202413 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo