Bug 201395 - New project not expanded
New project not expanded
Status: RESOLVED FIXED
Product: projects
Classification: Unclassified
Component: Generic Projects UI
7.1
All All
: P3 (vote)
: 7.1
Assigned To: Jesse Glick
issues@projects
: RANDOM, THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-29 12:59 UTC by Tomas Mysik
Modified: 2011-08-31 14:29 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Works for j2seproject, but nothing else (1.43 KB, patch)
2011-08-30 20:15 UTC, Jesse Glick
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Mysik 2011-08-29 12:59:37 UTC
Tried using PHP and Java project, steps:
- create new project, let the IDE generate some file

-> project is created but not expanded in the Projects view

Product Version: NetBeans IDE Dev (Build 20110829-4b48eadbbc4c)
Java: 1.6.0_24; Java HotSpot(TM) 64-Bit Server VM 19.1-b02
System: Linux version 2.6.38-11-generic running on amd64; UTF-8; cs_CZ (nb)
Comment 1 Jesse Glick 2011-08-30 19:54:26 UTC
Might be a regression, not sure. Does not happen in a debugger, so maybe timing-related. At first I suspected PackageRootNode.PathFinder was broken by the fix of bug #199391, but it seems to be something else. Maybe broken by fix of #55701? ProjectUtilities.openAndSelectNewObject runs, but then an inner block does not run.

Also selectAndExpandProject runs but finds nothing; probably broken by various UI responsiveness fixes.
Comment 2 Jesse Glick 2011-08-30 20:15:25 UTC
Created attachment 110288 [details]
Works for j2seproject, but nothing else
Comment 3 Jesse Glick 2011-08-30 20:16:29 UTC
Different events just seem to come at different times, and there is no clear way to order them.
Comment 4 Jesse Glick 2011-08-30 20:29:22 UTC
core-main #a32b3ca199be
Comment 5 Quality Engineering 2011-08-31 14:29:18 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/a32b3ca199be
User: Jesse Glick <jglick@netbeans.org>
Log: #201395: New project not expanded


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo