Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 201348 - Cannot finish debugger session
Cannot finish debugger session
Status: VERIFIED FIXED
Product: javaee
Classification: Unclassified
Component: Debugger
7.1
PC Windows XP
: P2 (vote)
: 7.1
Assigned To: Martin Entlicher
issues@javaee
: T9Y, TEST
: 202544 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-26 07:45 UTC by Jiri Skrivanek
Modified: 2011-09-23 17:22 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Skrivanek 2011-08-26 07:45:22 UTC
It is not possible to finish debugger session for web application with GlassFish server. I can reproduce it repeatedly but with different number of attempts. To reproduce:

- start IDE with empty user dir
- create web application with GlassFish server
- debug main project (Ctrl+F5)
- wait until page is opened in browser
- finish debugger session (Shift+F5). There is a message in Debugger Console that User program finished but Debugging window and toolbar are still present. If it is OK first time, try to repeat debug/finish until it happens (less than 10 attempts).

Product Version: NetBeans IDE Dev (Build 201108250601)
Java: 1.7.0; Java HotSpot(TM) Client VM 21.0-b17
System: Windows XP version 5.1 running on x86; Cp1250; en_US (nb)
Comment 1 Martin Entlicher 2011-09-18 16:11:11 UTC
Reproduced.
Comment 2 Martin Entlicher 2011-09-19 09:59:53 UTC
The random bug as caused by creation of two instances of JavaEngineProvider.
It's fixed by changeset:   202228:358037edc875
http://hg.netbeans.org/main/rev/358037edc875
Comment 3 Quality Engineering 2011-09-21 08:07:33 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/358037edc875
User: mentlicher@netbeans.org
Log: #201348 Wait for an instance that happens to be created by a parallel thread.
Comment 4 Jiri Skrivanek 2011-09-21 08:38:21 UTC
Verified in build 201109202329.
Comment 5 Martin Entlicher 2011-09-23 17:22:12 UTC
*** Bug 202544 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo