Bug 201257 - InternalError: processing event: -1
InternalError: processing event: -1
Status: RESOLVED FIXED
Product: ide
Classification: Unclassified
Component: Logger
7.0
All All
: P3 (vote)
: 7.2
Assigned To: Martin Entlicher
logger-issues@ide
EXCEPTIONS_REPORT
:
: 213412 214708 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-23 16:07 UTC by helderneres
Modified: 2012-06-25 12:22 UTC (History)
9 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.71 KB, text/plain)
2011-08-23 16:08 UTC, helderneres
Details
stacktrace (1.66 KB, text/plain)
2012-01-03 08:55 UTC, schkovich
Details
stacktrace (1.66 KB, text/plain)
2012-03-16 14:53 UTC, _ tboudreau
Details
stacktrace (1.74 KB, text/plain)
2012-03-21 16:37 UTC, aldobrucale
Details
stacktrace (1.74 KB, text/plain)
2012-03-22 15:16 UTC, aldobrucale
Details
stacktrace (1.65 KB, text/plain)
2012-03-22 17:31 UTC, aldobrucale
Details

Note You need to log in before you can comment on or make changes to this bug.
Description helderneres 2011-08-23 16:07:57 UTC
This bug was originally marked as duplicate of bug 180924, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE 7.0.1 (Build 201107282000)
VM: Java HotSpot(TM) Client VM, 20.1-b02, Java(TM) SE Runtime Environment, 1.6.0_26-b03
OS: Linux

User Comments:
helderneres: Restart after abrupt shutdown.

GUEST: Just opened the IDE

mcseemz: openeed application

nleck: opening IDE




Stacktrace: 
java.lang.InternalError: processing event: -1
   at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(XMLDocumentFragmentScannerImpl.java:507)
   at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:808)
   at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:737)
   at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(XMLParser.java:119)
   at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(AbstractSAXParser.java:1205)
   at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(SAXParserImpl.java:522)
Comment 1 helderneres 2011-08-23 16:08:02 UTC
Created attachment 110165 [details]
stacktrace
Comment 2 Kenneth Ganfield 2011-11-28 18:50:43 UTC
Product Version: NetBeans IDE 7.1 Beta (Build 201109252201)
Java: 1.6.0_29; Java HotSpot(TM) 64-Bit Server VM 20.4-b02-402
System: Mac OS X version 10.6.8 running on x86_64; MacRoman; en_US (nb)
Comment 3 schkovich 2012-01-03 08:55:09 UTC
Created attachment 114569 [details]
stacktrace

thrown during start up (opening link to the NetBeans web site on the top of the Start Page)
Comment 4 _ tboudreau 2012-03-16 14:53:15 UTC
Created attachment 116802 [details]
stacktrace

On restart after cmoputer powered off.
Comment 5 aldobrucale 2012-03-21 16:37:15 UTC
Created attachment 117027 [details]
stacktrace
Comment 6 aldobrucale 2012-03-22 15:16:15 UTC
Created attachment 117091 [details]
stacktrace

Opening a project (with Quick File Chooser)
Comment 7 aldobrucale 2012-03-22 17:31:13 UTC
Created attachment 117102 [details]
stacktrace

Open a project group
Comment 8 Martin Entlicher 2012-03-30 15:41:41 UTC
I've reproduced this with the XML file attached in the messages.log file.
Comment 9 Martin Entlicher 2012-04-03 11:53:22 UTC
I have finally identified the problem on line 3219:
<sequence><record>

This part of the XML is broken in http://statistics.netbeans.org/exceptions/messageslog?id=568136:
<record>
  <date>2012-03-22T12:44:29</date>
  <millis>1332416669429</millis>
  <sequence><record>
  <date>2012-03-22T12:50:13</date>
  <millis>1332417013861</millis>
  <sequence>31</sequence>
  <logger>org.netbeans.ui.metrics</logger>
  <level>INFO</level>
  <thread>12</thread>
  <message>USG_SYSTEM_CONFIG</message>
  <param>Linux, 3.0.0-16-generic-pae, i386</param>
  <param>Java HotSpot(TM) Client VM, 22.1-b02, Java(TM) SE Runtime Environment, 1.7.0_03-b04</param>
  <param>NetBeans IDE Dev (Build 201203210400)</param>
  <param>201203210400</param>
  <param>${buildday}</param>
  <param></param>
  <param>trunk</param>
  <param></param>
  <param>fab8d7e9e22b</param>
</record>

Similar broken segment is at line 8245 of the XML in http://statistics.netbeans.org/exceptions/messageslog?id=568098:
<exception>
   <message>java.io.IOException: No space left on device</message>
    <frame>
      <class>java.io.Fi<record>
  <date>2012-03-22T12:45:06</date>
  <millis>1332416706654</millis>
  <sequence>2970</sequence>
  <logger></logger>
  <level>SEVERE</level>
  <thread>42</thread>
  <message>java.io.IOException: No space left on device</message>
  <exception>
...

A part of the record is gone and next record continues after an unfinished element. This creates a broken XML file.
As the second log file suggests, this can happen when no more space is left on the device.
Comment 10 Quality Engineering 2012-04-04 10:10:59 UTC
Integrated into 'main-golden', will be available in build *201204040400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/c4694d883176
User: mentlicher@netbeans.org
Log: #201257: Remember and report the fatal parsing errors. This improves the ability to diagnose parsing failures.
Comment 11 Martin Entlicher 2012-04-04 17:49:00 UTC
Consistent output should prevent from this issue in the future:
changeset:   217787:a4804ab38877
http://hg.netbeans.org/main/rev/a4804ab38877
Comment 12 Quality Engineering 2012-04-05 09:41:17 UTC
Integrated into 'main-golden', will be available in build *201204050400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/a4804ab38877
User: mentlicher@netbeans.org
Log: #201257: DataConsistentFileOutputStream introduced to assure consistency of data written to the XML file. Also, when appendFile() fails, just undo the append.
Comment 13 Martin Entlicher 2012-06-04 12:18:40 UTC
*** Bug 213412 has been marked as a duplicate of this bug. ***
Comment 14 Martin Entlicher 2012-06-25 12:22:43 UTC
*** Bug 214708 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo