Bug 201248 - Mac OS cannot use "File->Open File From->(hostname)…"
Mac OS cannot use "File->Open File From->(hostname)…"
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Remote
7.0.1
Macintosh Solaris
: P3 (vote)
: 7.0.1
Assigned To: Alexander Simon
issues@cnd
CR_7082065, oss_ide_customer, 701patc...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-23 13:16 UTC by Alexander Simon
Modified: 2011-08-29 16:18 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Simon 2011-08-23 13:16:13 UTC
FULL PRODUCT VERSION :

java version "1.6.0_26"
Java(TM) SE Runtime Environment (build 1.6.0_26-b03-383-11A511)
Java HotSpot(TM) 64-Bit Server VM (build 20.1-b02-383, mixed mode)


ADDITIONAL OS VERSION INFORMATION :
Darwin dhcp-austin08-1fl-west-10-135-188-142.usdhcp.oraclecorp.com 11.1.0 Darwin Kernel Version 11.1.0: Tue Jul 26 16:07:11 PDT 2011; root:xnu-1699.22.81~1/RELEASE_X86_64 x86_64

This is on Mac OS X version 10.7.1.  bugreport.sun.com/bugreport  will not let me file a bug against something running on Mac OS X although http://www.oracle.com/technetwork/server-storage/solarisstudio/downloads/oss-12-3-beta-readme-435173.html does

Macintosh OS X 10.5 or later Macintosh OS X update

under System and Hardware Requirements.

EXTRA RELEVANT SYSTEM CONFIGURATION :
Product Version: Oracle Solaris Studio Dev 2011/07/29 bf7f65af6a35

System: Mac OS X version 10.7.1 running on x86_64; MacRoman; en_US (solstudio)


A DESCRIPTION OF THE PROBLEM :
I am running

Product Version: Oracle Solaris Studio Dev 2011/07/29 bf7f65af6a35
Java: 1.6.0_26; Java HotSpot(TM) 64-Bit Server VM 20.1-b02-383
System: Mac OS X version 10.7.1 running on x86_64; MacRoman; en_US (solstudio)
Userdir: /Users/dbeatty/Library/Application Support/solstudio/dd-12.3

connecting remotely to either scax1.sfbay.sun.com (Solaris 10) or scax2.sfbay.sun.com (OEL 5.6).

I created the desktop distribution zip file on scax2.

I cannot open files on either remote host.   A window appears (with a title like "Open File at dbx137753@scax1.sfbay.sun.com at db137753.scax1.sfba.sun.com", i.e., the "at..." part appears twice).

The window contains 4 areas.  First is a pop-up with the label "home" (the other choice is the name of my Mac).  Below that is a list of two columns, "Name" and "Date Modified."  The names in the list are the names of things that were at some point mounted by the automounter in /home on the remote machine.  If I use a separate shell window to ssh to the remote machine, and ls /home on it, it initially matches the "Name" column.  If I ls another user's home dir to force it to be mounted, the window does not update, and if I cancel it and then open it again, it still has the old contents.

For every item "Date Modified" is "Wednesday, December 31, 1969 6:00 PM".  (I am in the US Central time zone.)

Looks like something is not playing well with the automounter.

  Interestingly, If I use "File->Open Remote Project->(hostname)..." then I get a different window that lets me navigate the remote filesystem successfully.


STEPS TO FOLLOW TO REPRODUCE THE PROBLEM :
See Description.

EXPECTED VERSUS ACTUAL BEHAVIOR :
EXPECTED -
Expected to be able to browse filesystem of remote machine.
ACTUAL -
See Description.

REPRODUCIBILITY :
This bug can be reproduced always.
*** (#1 of 1): 2011-08-23 01:40:32 MSD kuldip.oberoi@oracle.com
Comment 1 Alexander Simon 2011-08-23 13:42:58 UTC
fixed, change set:
http://hg.netbeans.org/cnd-main/rev/2f486a5a66a4
Comment 2 Alexander Simon 2011-08-23 13:50:25 UTC
fix transplanted in release701_fixes on elif:
2f486a5a66a4 transplanted to 037e1abec34a
Comment 3 Alexander Pepin 2011-08-24 11:02:32 UTC
verified in sputnik OSS IDE build #3138 (20110824)
Comment 4 Alexander Simon 2011-08-24 11:45:16 UTC
integrated in release701_fixes:
037e1abec34a transplanted to 8ce197aa073b
Comment 5 Alexander Pepin 2011-08-29 16:18:58 UTC
verified in 7.0.1 patch1.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo