Bug 201244 - enhanced conditional breakpoint
enhanced conditional breakpoint
Status: RESOLVED DUPLICATE of bug 132066
Product: php
Classification: Unclassified
Component: Debugger
7.1
All All
: P3 (vote)
: 7.1
Assigned To: Ondrej Brejla
issues@php
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-23 10:02 UTC by luislobo
Modified: 2011-08-23 11:23 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description luislobo 2011-08-23 10:02:12 UTC
It would be very helpful in debugging to have the ability to breakpoint when some condition is reached, like: variable is <,=,>,isset, is null,  or set of variables meet a condition. Also it would be good if it supports also  'has changed' option.
It should work also with magic methods.
Comment 1 Ondrej Brejla 2011-08-23 11:23:39 UTC

*** This bug has been marked as a duplicate of bug 132066 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo