Bug 201137 - Deadlock in QuietEditorPane.setFont vs. DocumentView.getPreferredSpan
Deadlock in QuietEditorPane.setFont vs. DocumentView.getPreferredSpan
Status: RESOLVED DUPLICATE of bug 201293
Product: editor
Classification: Unclassified
Component: -- Other --
7.1
PC Linux
: P3 (vote)
: 7.2
Assigned To: Milutin Kristofic
issues@editor
: THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-19 18:09 UTC by Jesse Glick
Modified: 2012-05-30 11:43 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Thread dump (27.84 KB, text/plain)
2011-08-19 18:09 UTC, Jesse Glick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2011-08-19 18:09:10 UTC
Created attachment 110116 [details]
Thread dump

20110819-e42df7749e1e. Not sure if reproducible. Looks like DocumentViewOp.updateDefaultFontAndColors is illegally calling Swing methods off EQ.
Comment 1 Miloslav Metelka 2012-05-30 11:43:42 UTC

*** This bug has been marked as a duplicate of bug 201293 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo