Bug 200981 - AssertionError at org.netbeans.modules.cnd.modelimpl.repository.RepositoryUtils.put
AssertionError at org.netbeans.modules.cnd.modelimpl.repository.RepositoryUti...
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Code Model
7.0
All All
: P2 (vote)
: 7.1
Assigned To: Alexander Simon
issues@cnd
EXCEPTIONS_REPORT, 701patch2-verified...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-16 00:55 UTC by tbrunhoff
Modified: 2011-09-27 12:59 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.66 KB, text/plain)
2011-08-16 00:55 UTC, tbrunhoff
Details
manual transplantation patch (33.68 KB, patch)
2011-09-16 06:44 UTC, Alexander Simon
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description tbrunhoff 2011-08-16 00:55:32 UTC
Build: NetBeans IDE Dev (Build 201108080600)
VM: Java HotSpot(TM) Client VM, 19.0-b09, Java(TM) SE Runtime Environment, 1.6.0_23-b05
OS: Linux

User Comments:
tbrunhoff: Adding a new method declaration to a header file.




Stacktrace: 
java.lang.AssertionError
   at org.netbeans.modules.cnd.modelimpl.repository.RepositoryUtils.put(RepositoryUtils.java:185)
   at org.netbeans.modules.cnd.modelimpl.csm.InheritanceImpl.getClassifier(InheritanceImpl.java:149)
   at org.netbeans.modules.cnd.api.model.services.CsmInheritanceUtilities.getCsmClass(CsmInheritanceUtilities.java:410)
   at org.netbeans.modules.cnd.api.model.services.CsmVirtualInfoQuery$Empty.getBaseDeclaration(CsmVirtualInfoQuery.java:202)
   at org.netbeans.modules.cnd.api.model.services.CsmVirtualInfoQuery$Empty.getFirstBaseDeclarations(CsmVirtualInfoQuery.java:188)
   at org.netbeans.modules.cnd.navigation.overrides.ComputeAnnotations.computeAnnotation(ComputeAnnotations.java:123)
Comment 1 tbrunhoff 2011-08-16 00:55:36 UTC
Created attachment 109995 [details]
stacktrace
Comment 3 Quality Engineering 2011-08-18 13:49:52 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/d1c8c5546c14
User: Alexander Simon <alexvsimon@netbeans.org>
Log: fixed Bug #200981 AssertionError at org.netbeans.modules.cnd.modelimpl.repository.RepositoryUtils.put
Comment 4 tbrunhoff 2011-09-02 18:00:58 UTC
I've hit a number of new exceptions that are dups of this (see http://statistics.netbeans.org/analytics/detail.do?id=180629), but the code I am using post-dates your fix. Must be broken again or another bug with the same stack trace (or your fix is not yet in the nightly build). Sorry.


Product Version: NetBeans IDE Dev (Build 201108310601)
Java: 1.6.0_23; Java HotSpot(TM) Client VM 19.0-b09
System: Linux version 2.6.35.13-92.fc14.x86_64 running on i386; UTF-8; en_US (nb)
User directory: /home/toddb/.netbeans/dev
Cache directory: /home/toddb/.netbeans/dev/var/cache
Comment 5 Alexander Simon 2011-09-07 16:18:18 UTC
fixed, change set:
http://hg.netbeans.org/cnd-main/rev/083d8521efc3
Comment 6 Quality Engineering 2011-09-08 14:31:01 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/083d8521efc3
User: Alexander Simon <alexvsimon@netbeans.org>
Log: fixed Bug #200981 AssertionError at org.netbeans.modules.cnd.modelimpl.repository.RepositoryUtils.put
Comment 7 Alexander Simon 2011-09-16 06:44:11 UTC
Created attachment 110800 [details]
manual transplantation patch

Due to interrelated changes in trunk the change set 083d8521efc3 cannot be transplanted automatically.
This is manual transplantation path applicable to releases_elif.
Comment 8 Vladimir Voskresensky 2011-09-16 10:11:53 UTC
I reviewed the fix and it fixes regression introduced previously.
Comment 9 Alexander Simon 2011-09-16 10:27:14 UTC
manual transplanted in releases_elif branch release701_fixes
204862:d23c6d043800
Comment 10 Alexander Pepin 2011-09-21 15:56:13 UTC
can not reproduce in oss-platform-build #66 (20110921)
Comment 11 Quality Engineering 2011-09-26 13:29:56 UTC
Integrated into 'releases'
Changeset: http://hg.netbeans.org/releases/rev/d23c6d043800
User: Alexander Simon <alexvsimon@netbeans.org>
Log: fixed Bug #200981 AssertionError at org.netbeans.modules.cnd.modelimpl.repository.RepositoryUtils.put
- manual transplant of change set 083d8521efc3
Comment 12 Alexander Pepin 2011-09-27 12:59:20 UTC
can not reproduce in OSS dev build based on 7.0.1 patch2


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo