Bug 200689 - No indent for generated methods for gui events in 7.0.1
No indent for generated methods for gui events in 7.0.1
Status: VERIFIED FIXED
Product: editor
Classification: Unclassified
Component: Formatting & Indentation
7.0.1
PC Linux
: P1 (vote)
: 7.0.1
Assigned To: Dusan Balek
issues@editor
701patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-05 07:02 UTC by eugene-71
Modified: 2011-08-30 11:59 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description eugene-71 2011-08-05 07:02:11 UTC
When netbeans 7.0.1 generates method for gui event (for example, select jframe -> properties -> events -> windowClosing and generate method), generated methods is not indented, code starts from first column.

As code in non-editable, no way to indent it.

Bug introduced with 7.0.1 update.
Comment 1 Jan Stola 2011-08-08 13:14:43 UTC
It seems to be a regression in IndentEngine. Its writer no longer indents the header/footer of the method. Reassigning to editor module for evaluation.

FYI: The corresponding code (in GUI Builder) resides in JavaCodeGenerator.generateEventHandler()
Comment 2 Dusan Balek 2011-08-10 14:00:48 UTC
Fixed in jet-main.

http://hg.netbeans.org/jet-main/rev/411fa3c32453
Comment 3 Quality Engineering 2011-08-11 21:01:43 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/411fa3c32453
User: Dusan Balek <dbalek@netbeans.org>
Log: Issue #200689: No indent for generated methods for gui events in 7.0.1 - fixed.
Comment 4 Jiri Prox 2011-08-24 09:09:37 UTC
verified,

 please integrate this fix into release701_fixes branch, thanks

Product Version: NetBeans IDE Dev (Build 201108210601)
Java: 1.7.0; Java HotSpot(TM) Client VM 21.0-b17
System: Windows 7 version 6.1 running on x86; Cp1252; en_US (nb)
User directory: C:\Users\jprox\.netbeans\dev
Cache directory: C:\Users\jprox\.netbeans\dev\var\cache
Comment 5 Jan Lahoda 2011-08-25 08:12:27 UTC
http://hg.netbeans.org/releases/rev/c53c621d70ec
Comment 6 Quality Engineering 2011-08-26 04:26:55 UTC
Integrated into 'releases'
Changeset: http://hg.netbeans.org/releases/rev/c53c621d70ec
User: Dusan Balek <dbalek@netbeans.org>
Log: Issue #200689: No indent for generated methods for gui events in 7.0.1 - fixed.
Comment 7 Jiri Prox 2011-08-29 14:11:23 UTC
verified in patch1


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo