Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 200657 - Passwords from KDE KWallet not available for different versions of NetBeans
Passwords from KDE KWallet not available for different versions of NetBeans
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Options&Settings
7.0.1
PC Linux
: P2 (vote)
: 7.1.1
Assigned To: Theofanis Oikonomou
issues@platform
71patch1-verified
:
Depends on:
Blocks: 179839
  Show dependency treegraph
 
Reported: 2011-08-04 07:42 UTC by Tomas Mysik
Modified: 2012-02-15 18:27 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Mysik 2011-08-04 07:42:40 UTC
Steps:
- have KDE (maybe reproducible with Gnome, on Windows etc.)
- have NB version x.y
- save some password using Keyring
- instal NB version x.y+1
- password is not available since in KWallet, the folder is named "NetBeans IDE x.y" instead of just "NetBeans IDE"

Adding Jesse to CC, perhaps he could be interested (and knows the proper BZ component).

Thanks.

Product Version: NetBeans IDE 7.0.1 (Build 201107282000)
Java: 1.6.0_24; Java HotSpot(TM) 64-Bit Server VM 19.1-b02
System: Linux version 2.6.38-10-generic running on amd64; UTF-8; cs_CZ (nb)
Comment 1 Jesse Glick 2011-08-04 11:48:28 UTC
I am not sure who fixes bugs in KWalletProvider; initially contributed by psychollek but jtulach and ynov have done all subsequent fixes. If you have KDE you can probably help as well as anyone.

Looks like the problem is the usage of getApplicationName(true). I have no idea why you would want to pass the NB version string into any KWallet command. From API references it seems that NB passes the unversioned app name as 'folder' and the versioned app name as 'appid', but I do not know the significance of these parameters.
Comment 2 Yulia Novozhilova 2011-08-08 13:07:16 UTC
Actually unversioned app name is taken from org.netbeans.core.windows.view.ui.Bundle:CTL_MainWindow_Title_No_Project property which in fact contains version info(x.x.x for releases and Dev x.x.x for Development). I'm not sure it is a good idea to parse and cut this string in KWalletProvider. 

Jesse, do you know if there is another way to get the Application name without version information? Thanks.
Comment 3 Jesse Glick 2011-08-10 20:39:41 UTC
(In reply to comment #2)
> do you know if there is another way to get the Application name without
> version information?

No, I do not think so. Maybe just hardcode "NetBeans". I do not see any reason why you would want to maintain separate wallets for distinct NB-based apps (and the other providers do not attempt to do so).
Comment 4 Tomas Mysik 2011-11-04 12:32:12 UTC
Please, have a look at this issue since perhaps it might be P2 (moreover, it should be easily fixable, I hope).

Have a look at the steps in the initial description - keyring (stored passwords) simply does not work for every new version of NetBeans and one simply lost his/her passwords.

Thanks.
Comment 5 Tomas Mysik 2011-11-24 08:45:43 UTC
Sorry, I simply have to raise it to P2 since today I installed 7.1 RC1 and I have no available passwords stored in the previous version of NetBeans for:
- Hudson Builders
- Issue Trackers
- Servers
- Databases

Now, I have to provide all 33 (!) passwords again and moreover, I will need to do the same for NB 7.2 as well.

Please, simply do what Jesse suggests in Comment #3 (maybe consider "NetBeans IDE" as well).

Thanks.
Comment 6 Theofanis Oikonomou 2011-11-24 16:00:27 UTC
Proposed solution from comment 3 was adopted

http://hg.netbeans.org/core-main/rev/c38470392c50
Comment 7 Tomas Mysik 2011-11-24 16:19:56 UTC
Perfect, thanks a lot!
Comment 8 Quality Engineering 2011-11-25 16:22:38 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/c38470392c50
User: Theofanis Oikonomou <theofanis@netbeans.org>
Log: Issue #200657 - Passwords from KDE KWallet not available for different versions of NetBeans
Comment 9 hans_itaf_eu 2012-01-22 12:58:50 UTC
This bug is still in the latest 7.1 release.
It saves passwords in Kwallet as 'NetBeans IDE 7.1'.
Comment 10 Tomas Mysik 2012-01-23 07:44:57 UTC
Closing again, TM is 7.2, not 7.1.

Could this issue be a candidate for 7.1 patch, please?

Thanks.
Comment 11 Marian Mirilovic 2012-02-06 16:22:19 UTC
(In reply to comment #10)
> Could this issue be a candidate for 7.1 patch, please?

No problem Tomas, could you please verify the fix is working in the trunk ? Thanks in advance.
Comment 12 Tomas Mysik 2012-02-07 07:09:46 UTC
Yes, the fix works for me.

Thanks.
Comment 13 Marian Mirilovic 2012-02-07 08:19:36 UTC
(In reply to comment #12)
> Yes, the fix works for me.

Tomas, thanks a lot.

Fanis - you can proceed with integration ;)
Comment 14 Theofanis Oikonomou 2012-02-07 15:39:23 UTC
Thanks. Integrated

http://hg.netbeans.org/releases/rev/25472c65acaf
Comment 15 Quality Engineering 2012-02-08 02:34:04 UTC
Integrated into 'releases', will be available in build *201202072200* or newer. Wait for official and publicly available build.
Changeset: http://hg.netbeans.org/releases/rev/49dcc3320ae1
User: Theofanis Oikonomou <theofanis@netbeans.org>
Log: Issue #200657 - Passwords from KDE KWallet not available for different versions of NetBeans
(transplanted from c38470392c5077483859e6d5ec2a155e04a6f33d)
Comment 16 Tomas Danek 2012-02-15 14:25:25 UTC
Tomasi, could you please verify also in 7.1.1 RC1 build? (from smetiste). I do not have KDE installed:(
Thanks in advance:)


(In reply to comment #12)
> Yes, the fix works for me.
> 
> Thanks.
Comment 17 Tomas Mysik 2012-02-15 14:50:24 UTC
It works for me but I do not have a build from smetiste, I built it myself. Is it OK?

Product Version: NetBeans IDE 7.1.1 RC1 (Build 20120214-4d8c8290dbdf)
Java: 1.6.0_30; Java HotSpot(TM) 64-Bit Server VM 20.5-b03
System: Linux version 3.2.5 running on amd64; UTF-8; cs_CZ (nb)
Comment 18 Tomas Danek 2012-02-15 18:27:12 UTC
it is, thanks Tomasi!


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo