Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 200623 - Problem uploading files: Cannot change to the remote directory
Problem uploading files: Cannot change to the remote directory
Status: VERIFIED WORKSFORME
Product: php
Classification: Unclassified
Component: FTP Support
7.1
PC Windows XP
: P3 (vote)
: 7.1
Assigned To: Tomas Mysik
issues@php
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-03 09:15 UTC by Vladimir Riha
Modified: 2011-10-27 11:41 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
screenshot (43.36 KB, image/png)
2011-08-03 09:15 UTC, Vladimir Riha
Details
log with -J-Dorg.netbeans.modules.php.project.connections.level=FINE (53.96 KB, application/octet-stream)
2011-08-03 13:06 UTC, Vladimir Riha
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Riha 2011-08-03 09:15:31 UTC
Created attachment 109764 [details]
screenshot

Steps to reproduce:
- create new php project from remote server (sftp)
- change some file, save it (upload is set to "On Save")
- wait 6-10minutes
- edit the file again and save it, during uploading this dialog is shown "Upload files on save failed (more information in IDE log). Disable this functionality for
PROJECTNAME for this session?"

The log says:
INFO [org.netbeans.modules.php.project.copysupport.RemoteOperationFactory]: Upload failed: org.netbeans.modules.php.project.connections.transfer.TransferInfo [transfered: [], failed: {LocalTransferFile[name: index.php, remotePath: index.php, baseDirectory: C:\xampp\htdocs3\PhpProject25, hasParent: false, isFile: true, isDirectory: false, isLink: false]=Reason: Cannot change to the remote directory /.}, partially failed: {}, ignored: {}, runtime: 31 ms]

I attached screen from run configuration and from Manage remote connections
Comment 1 Tomas Mysik 2011-08-03 10:06:15 UTC
Since I cannot reproduce myself, could you please start NB with

-J-Dorg.netbeans.modules.php.project.connections.level=FINE

reopen this issue and attach your IDE log?

Thanks a lot.
Comment 2 Vladimir Riha 2011-08-03 13:06:14 UTC
Created attachment 109768 [details]
log with -J-Dorg.netbeans.modules.php.project.connections.level=FINE

Here's the second log. I'm not sure what does it say, but I tried other SFTP server and I wasn't able to reproduce it, so it's possible that the problem is caused by some bug in the first server.
Comment 3 Tomas Mysik 2011-08-03 13:27:20 UTC
(In reply to comment #2)
> I tried other SFTP server and I wasn't able to reproduce it

The same for me - would it be possible to try the previous SFTP server? If yes, please reopen this issue and attach IDE log with finer logging enabled.

Thanks a lot.
Comment 4 Vladimir Riha 2011-08-03 13:33:04 UTC
I'm sorry I didn't write it clearly. The log from commen #2 is from the first, not working correctly, server. After that I tried some other just to be sure (and from this working one I didn't attached log)
Comment 5 Tomas Mysik 2011-08-03 13:56:03 UTC
So, it seems that it was a problem of the server, from the log:

FINE [org.netbeans.modules.php.project.connections.sftp.SftpClient]: Error while changing directory /
java.io.IOException: Pipe closed

So it seems that the server closed the current session?

Anyway, closing as WORKSFORME since it really seems that the fault was on the side of your SFTP server.

Thanks.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo