Bug 200608 - NullPointerException at org.netbeans.modules.profiler.ppoints.StopwatchProfilingPoint$Report.initComponents
NullPointerException at org.netbeans.modules.profiler.ppoints.StopwatchProfil...
Status: VERIFIED FIXED
Product: profiler
Classification: Unclassified
Component: Base
7.0
All All
: P2 (vote)
: 7.1
Assigned To: Jiri Sedlacek
issues@profiler
EXCEPTIONS_REPORT, 701patch1-verified
: REGRESSION
: 200609 208261 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-02 16:21 UTC by Petr Cyhelsky
Modified: 2012-02-10 15:47 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (4.31 KB, text/plain)
2011-08-02 16:21 UTC, Petr Cyhelsky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Cyhelsky 2011-08-02 16:21:01 UTC
Build: NetBeans IDE 7.0.1 (Build 201107282000)
VM: Java HotSpot(TM) Client VM, 21.0-b17, Java(TM) SE Runtime Environment, 1.7.0-b147
OS: Linux

User Comments:
mjreged: While trying to profile a maven based junit test.  Setup stopwatch profiler point and run the test. At the end of the test Results = No results available. Double click causes the NPE

cyhelsky: the report for the profiling points is not shown due to this NPE (it occurs when you click on the "report" link)




Stacktrace: 
java.lang.NullPointerException
   at org.netbeans.modules.profiler.ppoints.StopwatchProfilingPoint$Report.initComponents(StopwatchProfilingPoint.java:313)
   at org.netbeans.modules.profiler.ppoints.StopwatchProfilingPoint$Report.<init>(StopwatchProfilingPoint.java:131)
   at org.netbeans.modules.profiler.ppoints.StopwatchProfilingPoint.getReport(StopwatchProfilingPoint.java:582)
   at org.netbeans.modules.profiler.ppoints.StopwatchProfilingPoint.showResults(StopwatchProfilingPoint.java:467)
   at org.netbeans.modules.profiler.ppoints.ProfilingPoint$ResultsRenderer.handleLink(ProfilingPoint.java:109)
   at org.netbeans.lib.profiler.ui.components.table.HTMLLabelTableCellRenderer$1.showURL(HTMLLabelTableCellRenderer.java:77)
Comment 1 Petr Cyhelsky 2011-08-02 16:21:05 UTC
Created attachment 109752 [details]
stacktrace
Comment 2 Petr Cyhelsky 2011-08-02 16:51:19 UTC
*** Bug 200609 has been marked as a duplicate of this bug. ***
Comment 3 Petr Cyhelsky 2011-08-02 16:55:31 UTC
Caused by fix of bug 4129681 in JDK: http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=4129681
Comment 4 Petr Cyhelsky 2011-08-02 16:56:46 UTC
Workaround is to run IDE on JDK 1.6
Comment 5 Tomas Hurka 2011-08-02 20:12:17 UTC
In JDK 7 TitledBorder.getTitleFont() returns null in StopwatchProfilingPoint$Report.initComponents()
Comment 6 Tomas Hurka 2011-08-03 12:14:27 UTC
Fixed in main

changeset:   198058:1b862d81f325
user:        Jiri Sedlacek <jis@netbeans.org>
date:        Wed Aug 03 14:08:45 2011 +0200
summary:     bugfix #200608, TitledBorder.getTitleFont() can return null - compute title font in Utils.getTitledBorderFont()
Comment 7 Quality Engineering 2011-08-04 13:48:28 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/1b862d81f325
User: Jiri Sedlacek <jis@netbeans.org>
Log: bugfix #200608, TitledBorder.getTitleFont() can return null - compute title font in Utils.getTitledBorderFont()
Comment 8 Petr Cyhelsky 2011-08-15 12:40:51 UTC
verified on:
Product Version: NetBeans IDE Dev (Build 201108040600)
Java: 1.6.0_26; Java HotSpot(TM) 64-Bit Server VM 20.1-b02
System: Linux version 2.6.38-10-generic running on amd64; UTF-8; en_US (nb)
Comment 9 Petr Cyhelsky 2011-08-19 07:07:13 UTC
re-verified(needs to be verified on jdk7) on: 
Product Version: NetBeans IDE Dev (Build 201108040600)
Java: 1.7.0; Java HotSpot(TM) Client VM 21.0-b17
System: Linux version 2.6.38-10-generic running on i386; UTF-8; en_US (nb)
Comment 10 Jiri Sedlacek 2011-08-24 11:32:28 UTC
Transplanted to release701_fixes.
Comment 11 Quality Engineering 2011-08-25 04:24:52 UTC
Integrated into 'releases'
Changeset: http://hg.netbeans.org/releases/rev/6d9b7a91b2b3
User: Jiri Sedlacek <jis@netbeans.org>
Log: bugfix #200608, TitledBorder.getTitleFont() can return null - compute title font in Utils.getTitledBorderFont()
(transplanted from 1b862d81f3255548c1cfee5bdc12274b49a3518f)
Comment 12 Petr Cyhelsky 2011-08-26 09:32:39 UTC
patch verified on latest UC build
Comment 13 Tomas Hurka 2012-02-10 15:47:24 UTC
*** Bug 208261 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo