Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 200561 - Uninstall doesn't offer to remove custom usedir on Win 7
Uninstall doesn't offer to remove custom usedir on Win 7
Status: RESOLVED INVALID
Product: installer
Classification: Unclassified
Component: Code
7.0.1
PC Windows 7 x64
: P3 (vote)
: TBD
Assigned To: Yulia Novozhilova
issues@installer
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-01 09:27 UTC by Stepan Zebra
Modified: 2011-08-10 10:32 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
uninstall log (20.26 KB, text/plain)
2011-08-08 11:56 UTC, Stepan Zebra
Details
netbeans.conf (1.50 KB, text/plain)
2011-08-08 16:38 UTC, Stepan Zebra
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stepan Zebra 2011-08-01 09:27:10 UTC
Product Version: NetBeans IDE 7.0.1 (Build 201107282000)
Java: 1.7.0; Java HotSpot(TM) 64-Bit Server VM 21.0-b17
System: Windows 7 version 6.1 running on amd64; Cp1252; en_US (nb)

If user changes his default userdir, installer no longer offers its removal. This behavior was experienced only on Windows 7 with 7.0 and 7.0.1 installers.

Steps to reproduce:
1) install NetBeans 7.0.1 on Windows 7 machine
2) edit %installdir%\NetBeans 7.0.1\etc\netbeans.conf and change the name of default userdir from "7.0" to "myname"
3) run IDE and create sample project
4) exit IDE and run uninstall
Comment 1 Yulia Novozhilova 2011-08-05 16:24:49 UTC
I'll try to find Windows 7 machine to reproduce. Meanwhile, could you please, recheck that you have write access to the custom userdir and it is not empty when running ununstaller. Thanks.
Comment 2 Stepan Zebra 2011-08-08 08:56:53 UTC
The userdir isn't empty and IDE works fine with it. Also all permissions should be ok.

The installer just seems to ignore the netbeans.conf file.

I can for example manually rename the actual usedir from "myname" to the default "7.0" without changing the netbeans.conf. Then uninstaller offers to remove this "7.0" usedir. Even though the IDE isn't actually using this directory now (still "myname" in netbeans.conf).
Comment 3 Yulia Novozhilova 2011-08-08 10:05:11 UTC
Could you please attach here %USER_DIR%\.nbi\log\*.log file that is created after uninstallation (you can just run uninstaller and cancel it at the last moment right before the actual uninstallation). Thanks in advance
Comment 4 Stepan Zebra 2011-08-08 11:56:16 UTC
Created attachment 109853 [details]
uninstall log

log from uninstall attempt in which userdir was set to "myname" and wasn't offered for removal
Comment 5 Yulia Novozhilova 2011-08-08 14:46:25 UTC
Thank you. According to the log there is no any exception during netbeans.conf reading. I've just tested it on Windows 7 machine and couldn't reproduce the issue. Probably something is misconfigured on your machine, could you please attach netbeans.conf file here?
Do you experience this problem with development builds? If so I'll be able to add some debug info into daily build to figure out what is wrong. Thank you.
Comment 6 Stepan Zebra 2011-08-08 16:38:46 UTC
Created attachment 109866 [details]
netbeans.conf

Nothing unusual with the configuration file, I guess.

Daily build have the same trouble. When I set the usedir to something different than the default "dev", uninstaller won't remove it.

I tried to make my machine as clean as possible before the install/uninstall, but on Windows no one ever knows. So I'll try another machine and report back.
Comment 7 Stepan Zebra 2011-08-10 10:32:29 UTC
RESOLUTION:

Because I changed the netbeans.conf with PSPad after IDE installation, my settings were saved into Virtual Store. IDE started to use the settings from the Virtual Store and during first run, it created an userdir in my custom folder. When I then run uninstall, the original netbeans.conf from it's location (%programfiles%\%installdir%\etc) is used and because it contains the original unchanged userdir that was never created, installer doesn't offer the removal.

BACKGROUND:

I run Windows with a single Administrator account with default UAC. This means that programs defaultly runs in User mode. To run a program in an Administrator mode, explicit request and authorization is required.
I use PSPad for editing text files. PSPad runs in User mode. When I open, edit and then want to save netbeans.conf file, there is no access denied message and the file is saved. Although the file seems to be overwritten in it's loacation (%programfiles%\%installdir%\etc), it is actually written into Virtual Store. So there are two config files now.
When I start Netbeans, the config file from Virtual Store is used. If I try to edit the config file in it's location (%programfiles%\%installdir%\etc) with PSPad again, the file from Virtual Store is used.
On the other hand, when I open the config file in it's location (%programfiles%\%installdir%\etc) with Windows Notepad or the NetBeans Editor, I always see the original file, not the one from Virtual Store. Also I'm not able to save changes to it.
When I run any of these programs in Administrator mode, it always opens the original config file from it's location (%programfiles%\%installdir%\etc), regardless of what is in Virtual Store. When I change the file now and save it, the original file is overwritten and Virtual Store isn't used.

NEXT:

Although installer works fine in a sense of this issue, i would still like to ask for a better handling of the Virtual Store. I'll open a new enhancement request in which i'll explain details.

Thank you for your time.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo