Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 200517 - Context help for "Add Web Service..." action is not working in JavaSE distro
Context help for "Add Web Service..." action is not working in JavaSE distro
Status: RESOLVED FIXED
Product: usersguide
Classification: Unclassified
Component: Web Services
7.0.1
All All
: P4 (vote)
: 7.1
Assigned To: Jeffrey Rubinoff
issues@usersguide
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-29 13:01 UTC by Jiri Kovalsky
Modified: 2011-10-05 22:40 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Kovalsky 2011-07-29 13:01:43 UTC
Product Version: NetBeans IDE 7.0.1 (Build 201107282000)
Java: 1.7.0; Java HotSpot(TM) 64-Bit Server VM 21.0-b17
System: Linux version 2.6.35-22-generic running on amd64; UTF-8; cs_CZ (nb)
Userdir: /home/cesilko/.netbeans/7.0

Description:
============
System help in NetBeans 7.0.1 is not context sensitive for "Add Web Service..." action if Web Services features are not activated/installed yet. It opens Help window but it does not display desired content user needs help with.

Steps to reproduce:
===================
1. Install JavaSE distribution of NetBeans IDE 7.0.1 RC build #201107282000.
2. Switch to "Services" view.
3. Right click "Web Services" node and choose "Add Web Service..." action.
4. Press "Help" button.
5. Help window will get opened but the content panel will show default "This
window contains the master set of all installed documentation..." message or previously displayed help page.
Comment 1 Kenneth Ganfield 2011-07-29 13:50:33 UTC
see my comments to 200516 re Add Server wizard
Comment 2 Denis Anisimov 2011-09-19 10:40:33 UTC
I'm not sure if it correct product.
Please reassign it if I'm wrong.

The problem is generic and is not specific to the webservices.
Help works perfectly if there is complete JavaEE distribution.
JavaSE contains websvc.saas.* modules which are JEE modules but doesn't contains
j2ee.platform module which has javahelp for JEE functionality.

So either Javahelp should be refactored and required parts should be moved in 
appropriate modules or this is JavaSE distribution problem.
In any case this is not webservices functionality.
It works correctly if javahelp is available.
Comment 3 Antonin Nebuzelsky 2011-09-29 13:22:37 UTC
Not an issue of platform / Help System which is only an infrastructure, not responsible for whoever registers helpsets and help ids.

Reassigning back to webservices. It needs to be resolved between the modules which register the helpset and which register the help IDs for context help.
Comment 4 Jeffrey Rubinoff 2011-10-02 22:09:07 UTC
I will refactor help. Downgrading priority because works on EE and Help provides absolutely no information that is not already in the dialog. (Help explains that Add Web Service dialog adds a web service.)
Comment 5 Jeffrey Rubinoff 2011-10-05 22:40:10 UTC
Fixed in trunk. Updated the Services window context help while I was at it.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo