Bug 200463 - Server items disappear on step back in "Add Server Instance" wizard
Server items disappear on step back in "Add Server Instance" wizard
Status: RESOLVED FIXED
Product: serverplugins
Classification: Unclassified
Component: Infrastructure
7.0.1
PC Windows 7
: P4 (vote)
: 7.2
Assigned To: Petr Hejl
issues@serverplugins
: ERGONOMICS
: 201985 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-28 11:16 UTC by Petr Cyhelsky
Modified: 2012-04-07 10:11 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
See the missing server items (23.22 KB, image/png)
2011-07-28 11:17 UTC, Petr Cyhelsky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Cyhelsky 2011-07-28 11:16:27 UTC
Product Version: NetBeans IDE 7.0.1 (Build 201107211357)
Java: 1.7.0; Java HotSpot(TM) Client VM 21.0-b17
System: Windows 7 version 6.1 running on x86; Cp1252; en_US (nb)

Steps to reproduce:
Start NB with fresh userdir -> go to services tab -> invoke popup on Servers node -> select Add Server -> in the Add server instance wizard select some server other than glassfish (jboss, oracle weblogic...) -> click next -> wait for j2ee to activate -> click back -> see the result - see attached screenshot
Comment 1 Petr Cyhelsky 2011-07-28 11:17:48 UTC
Created attachment 109666 [details]
See the missing server items
Comment 2 Petr Cyhelsky 2011-09-12 08:57:56 UTC
*** Bug 201985 has been marked as a duplicate of this bug. ***
Comment 3 David Konecny 2011-09-13 20:21:14 UTC
This is ergonomics issue.
Comment 4 Jaroslav Tulach 2011-11-04 12:33:32 UTC
Is not it more likely the dialog is not ready for changing the set of providers while being displayed?
Comment 5 Jaroslav Tulach 2011-12-05 10:36:43 UTC
As I said, imho the primary problem is that the dialog is not ready for list of providers to change while it is open.
Comment 6 Petr Hejl 2012-04-06 09:25:11 UTC
Fixed in web-main 5862cd930f4a.
Comment 7 Quality Engineering 2012-04-07 10:11:26 UTC
Integrated into 'main-golden', will be available in build *201204070400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/5862cd930f4a
User: Petr Hejl <phejl@netbeans.org>
Log: #200463 Server items disappear on step back in "Add Server Instance" wizard


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo