Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 200459 - Context help for several actions is broken
Context help for several actions is broken
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Help System
7.0.1
PC Linux
: P1 (vote)
: 7.0.1
Assigned To: Stanislav Aubrecht
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-28 10:54 UTC by Jiri Kovalsky
Modified: 2011-07-29 14:09 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Kovalsky 2011-07-28 10:54:11 UTC
Product Version: NetBeans IDE 7.0.1 (Build 201107211357)
Java: 1.7.0; Java HotSpot(TM) 64-Bit Server VM 21.0-b17
System: Linux version 2.6.35-22-generic running on amd64; UTF-8; cs_CZ (nb)
Userdir: /home/cesilko/.netbeans/7.0

Description:
============
System help in NetBeans 7.0.1 is not context sensitive for some actions. A short test discovered that pressing "Help" button in "New project...", "Add server..." or "Add web service..." wizards only opens Help window and does not display desired content user needs help with. This feature is then almost useless. Please note that this is a regression against NetBeans 7.0 where context help is fully working.

Steps to reproduce:
===================
1. Launch NetBeans IDE 7.0.1 RC build #201107211357.
2. Invoke "File > New Project..." from main menu.
3. Once the wizard opens press "Help" button.
4. Help window will get opened but the content panel will show default "This window contains the master set of all installed documentation..." message.
Comment 1 Marian Mirilovic 2011-07-28 11:33:49 UTC
Tonda, could somebody evaluate this issue ASAP ? Thanks in advance.
Comment 2 Antonin Nebuzelsky 2011-07-28 12:29:26 UTC
Standa will evaluate.
Comment 3 Stanislav Aubrecht 2011-07-28 12:34:42 UTC
there is no help topic for ID "org.netbeans.modules.project.ui.ProjectTemplatePanel"

so this is either a bug in 'new project' wizard which should provide help according to the selected template or it's a bug in the documentation because the help topic is missing.

probably someone from the docs teams should look at it as well.
Comment 4 Antonin Nebuzelsky 2011-07-28 13:05:09 UTC
>probably someone from the docs teams should look at it as well

Ken is looking into it.
Comment 5 Kenneth Ganfield 2011-07-28 13:22:24 UTC
It seems that the Help id for the New Project wizard was changed sometime after
7.0.

In IDE 7.0, the Help id for the New Project wizard was:
org.netbeans.modules.project.ui.TemplatesPanel 
This correctly maps to the topic New Project Wizard: Choose Project

In IDE build 201107270600, the Help id for the New Project wizard is:
org.netbeans.modules.project.ui.ProjectTemplatePanel

To fix the broken mapping, the help id should either be reverted back to the
previous id or id updated in the docs mapping file
Comment 6 Stanislav Aubrecht 2011-07-28 13:44:16 UTC
seems to be jesse's fault, he renamed TemplatesPanel to ProjectTemplatesPanel in 9eccae5cfb39
Comment 7 Marian Mirilovic 2011-07-28 13:50:06 UTC
(In reply to comment #6)
> seems to be jesse's fault, he renamed TemplatesPanel to ProjectTemplatesPanel
> in 9eccae5cfb39

Ok, are we able to fix it today ?
Comment 8 Stanislav Aubrecht 2011-07-28 13:59:27 UTC
missing help for 'add server' wizard is help id  "registering_app_server_hk2_location". that help id is available after activating j2ee feature. then the help displays fine.
Comment 9 Kenneth Ganfield 2011-07-28 14:01:44 UTC
http://hg.netbeans.org/main/rev/430e7332dc70

this fixes mapping problem for New Project wizard
Comment 10 Stanislav Aubrecht 2011-07-28 14:57:56 UTC
transplanted as 279ddb57393c to release701 branch

please open new issue(s) for 'add server' and 'add web service' help problems. they're ergonomics related anyway
Comment 11 Jesse Glick 2011-07-28 21:49:59 UTC
(In reply to comment #6)
> seems to be jesse's fault, he renamed TemplatesPanel to ProjectTemplatesPanel
> in 9eccae5cfb39

Right. Seems like it could be a general risk; filing bug #200499.
Comment 12 Quality Engineering 2011-07-29 03:29:27 UTC
Integrated into 'releases'
Changeset: http://hg.netbeans.org/releases/rev/279ddb57393c
User: kganfield <kganfield@netbeans.org>
Log: #200459, updating help id in map file after id was changed in wizard
(transplanted from 430e7332dc70dd136e18af9aa718021737e23448)
Comment 13 Jiri Kovalsky 2011-07-29 09:47:46 UTC
Verified in NetBeans IDE 7.0.1 RC build #201107282000. I will file new issues for "Add server..." and "Add web service..." wizards as you suggest. Thanks to all for the quick evaluation and fix!
Comment 14 Jiri Kovalsky 2011-07-29 13:04:14 UTC
FYI, the other context help related bugs are: issue #200514, issue #200516 and issue #200517.
Comment 15 Quality Engineering 2011-07-29 14:09:52 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/430e7332dc70
User: kganfield <kganfield@netbeans.org>
Log: #200459, updating help id in map file after id was changed in wizard


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo