Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 200412 - Critical error after 7.0 -> 7.0.1 autoupdate
Critical error after 7.0 -> 7.0.1 autoupdate
Status: CLOSED INCOMPLETE
Product: javame
Classification: Unclassified
Component: Visual Designer
7.0.1
PC Windows 7 x64
: P3 (vote)
: 7.2
Assigned To: Jan Stola
issues@mobility
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-27 10:06 UTC by Stepan Zebra
Modified: 2012-10-30 10:18 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
error windows screenshot (274.93 KB, image/png)
2011-07-27 10:06 UTC, Stepan Zebra
Details
log from corrupted ide (37.61 KB, text/plain)
2011-07-28 09:08 UTC, Stepan Zebra
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stepan Zebra 2011-07-27 10:06:59 UTC
Created attachment 109633 [details]
error windows screenshot

Product Version: NetBeans IDE 7.0.1 (Build 201107211357)
Java: 1.7.0; Java HotSpot(TM) 64-Bit Server VM 21.0-b17
System: Windows 7 version 6.1 running on amd64; Cp1252; en_US (nb)

After updating from 7.0 to 7.0.1 with autoupdate method, error windows are shown and any Visual Designer file can't be opened into editor (throws NPE instead). Projects can be still build and run in the emulator.

The situation seems to happen only if the autoupdate is performed on IDE which is installed into "Program Files" folder, for which there are permissions conflict on Windows 7. This results in whole update placed into userdir, instead of IDE installation directory. So not sure if this is more mobility issue or autoupdate issue.
Comment 1 Marian Mirilovic 2011-07-27 12:06:20 UTC
Anton, 
could you please evaluate ASAP ? I would like to know how long it will take to fix it, how risky is the fix and whether there is any possible workaround. Also would like to know whether we can fix it only in the next 7.0.1 patch .
Comment 2 Anton Chechel 2011-07-27 16:08:02 UTC
Works for me. Reopen if it will be reproducible again please.
Comment 3 Marian Mirilovic 2011-07-28 07:45:49 UTC
Stepan was able to reproduce it .. so reopening. Needs to be evaluated - I do not think it's a stopper for 7.0.1, but wait for evaluation from jrechtacek.
Comment 4 Stepan Zebra 2011-07-28 09:08:58 UTC
Created attachment 109660 [details]
log from corrupted ide

I'm attaching log from a single run of the corrupted IDE after update. IDE behaves as shown on the screenshot. There are some warnings in the log from Mobility and then an exception when I try to open some Visual Designer file.
Comment 5 Stepan Zebra 2011-07-29 09:32:19 UTC
After more attempts, I still don't have the exact case which triggers this. However it seems to happen only under a combination of unusual conditions. I can't reproduce it using 'normal' workflow.

Users won't most likely ever face this.

I have backed up the corrupted installation, so it's available from me for research.
Comment 6 Stepan Zebra 2012-10-30 10:18:22 UTC
unknown conditions, no similar reports
Comment 7 Stepan Zebra 2012-10-30 10:18:34 UTC
closing


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo