Bug 200376 - Upgrading Java SE to Full pack disables "Apply Code Changes" action
Upgrading Java SE to Full pack disables "Apply Code Changes" action
Status: VERIFIED FIXED
Product: debugger
Classification: Unclassified
Component: Java
7.0.1
PC Linux
: P2 (vote)
: 7.0.1
Assigned To: Martin Entlicher
issues@debugger
701patch1-verified
:
: 200922 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-25 20:20 UTC by Jiri Kovalsky
Modified: 2011-08-24 07:09 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Kovalsky 2011-07-25 20:20:20 UTC
Product Version: NetBeans IDE 7.0.1 (Build 201107211357)
Java: 1.7.0; Java HotSpot(TM) 64-Bit Server VM 21.0-b17
System: Linux version 2.6.35-22-generic running on amd64; UTF-8; cs_CZ (nb)
Userdir: /home/cesilko/.netbeans/7.0

It seems that some module from Full distribution makes "Debug > Apply Code Changes" menu action always disabled. In Java SE pack this action works fine but upgrading to Full distro causes this menu item to be greyed out even after editing file and saving it during debugging session.

Steps to reproduce:
===================
1. Download Java SE pack of NetBeans IDE 7.0.1 RC build #201107211357.
2. Launch it with empty userdir, ignore import of settings and install JUnit.
3. Go to "Tools > Plugins", disable "Certified Plugins" and "Plugin Portal" Update Centers and switch to "Available Plugins".
4. Invoke "Check All" from popup menu, then click "Install" and complete the process. Restart the IDE.
5. Generate Anagram Game sample project and make sure it has turned on "Compile on Save" ("Properties" > "Debug | Compiling").
6. Toggle line breakpoint at line 80 in Anagrams.java.
7. Invoke "Debug > Debug Main Project" and wait until the breakpoint is hit.
8. Create new line 81 containing  System.out.println("Hello World!!!"); code.
9. Invoke "File > Save" from main menu.
10. Now try to invoke "Debug > Apply Code Changes" but this action will be disabled.
Comment 1 Martin Entlicher 2011-07-26 10:01:54 UTC
Thanks for the detailed steps. I've reproduced the bug.
Comment 2 Jiri Kovalsky 2011-07-26 14:33:40 UTC
Not a stopper for 7.0.1 but a good candidate for its patch.
Comment 3 Jiri Kovalsky 2011-08-05 10:18:59 UTC
Martine, any progress on this bug? FYI, release701_fixes branch has been created for 7.0.1 Patch 1. Thanks for your update.
Comment 4 Martin Entlicher 2011-08-15 12:48:14 UTC
*** Bug 200922 has been marked as a duplicate of this bug. ***
Comment 5 Martin Entlicher 2011-08-15 12:49:48 UTC
It looks like activation of PHP plugin causes the Apply Code Changes action to stop working, as described in issue #200922.
Comment 6 Martin Entlicher 2011-08-15 19:04:21 UTC
It's fixed by changeset:   199068:5986994aacd1
http://hg.netbeans.org/main/rev/5986994aacd1

Can you please verify the fix after it gets propagated into the daily build, so that I can integrate it into release701_fixes branch? Thanks.
Comment 7 Jiri Kovalsky 2011-08-15 19:24:33 UTC
Sure, I will do my best.
Comment 8 Quality Engineering 2011-08-16 13:53:30 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/5986994aacd1
User: mentlicher@netbeans.org
Log: #200376: Assure that the correct SourcePathProvider is used.
Comment 9 Jiri Kovalsky 2011-08-17 13:41:04 UTC
I tested it in NetBeans 7.1 development build #201108160601 and it worked fine. However, I couldn't upgrade the Java SE pack to Full distro, because there is no NetBeans Distribution Update Center available. So I at least installed all available modules from both Development Update Centers.

Martine, please integrate the fix to release701_fixes branch.
Comment 10 Jiri Kovalsky 2011-08-18 10:55:38 UTC
Based on my yesterday's testing changing status to VERIFIED.
Comment 11 Martin Entlicher 2011-08-18 13:00:04 UTC
The fix is merged into release701_fixes branch:
changeset:   205136:fd7e9e2f2487
http://hg.netbeans.org/releases/rev/fd7e9e2f2487

The Specification Version is increased and link to patches info is added in
changeset:   205137:2f0fb1a3e4fb
http://hg.netbeans.org/releases/rev/2f0fb1a3e4fb
Comment 12 Jiri Kovalsky 2011-08-23 15:49:43 UTC
Verified in 7.0.1 patched with 2011-08-23_11-01-53 update.
Comment 13 Jiri Kovalsky 2011-08-24 07:09:30 UTC
Updating whiteboard status accordingly.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo