Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 200347 - Reporter suggests to "upgrade" NetBeans to an older version
Reporter suggests to "upgrade" NetBeans to an older version
Status: RESOLVED FIXED
Product: ide
Classification: Unclassified
Component: Exceptions Reporter
7.0
All All
: P2 (vote)
: 7.1
Assigned To: Tomas Danek
logger-issues@ide
:
: 203195 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-25 12:08 UTC by Martin Entlicher
Modified: 2011-11-03 12:28 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Entlicher 2011-07-25 12:08:08 UTC
Product Version = NetBeans IDE 7.0 (Build 201104080000)
Operating System = Linux version 2.6.38-10-generic-pae running on i386
Java; VM; Vendor = 1.6.0_16
Runtime = Java HotSpot(TM) Client VM 14.2-b01

An exception has occured in NetBeans IDE 7.0. When I pressed Report Exception, I got this message:

NetBeans Error Report Upload Complete
It has now been added to the database with id #520459. It has been classified as a duplicate of report #164915.
This bug was already fixed.
Please update your build of NetBeans to the latest build of 6.9 where bug #180348 is fixed. If you are already using a newer build and your report meets certain criteria a new bug will be filed automatically.
Your previous reports
Thanks again for your help.  The NetBeans development team!

I have NetBeans IDE 7.0, therefore I'd expect it to submit a *new* bug.
Comment 1 Marian Mirilovic 2011-10-10 08:24:37 UTC
*** Bug 203195 has been marked as a duplicate of this bug. ***
Comment 2 Tomas Danek 2011-11-01 15:54:46 UTC
i was able to reproduce on testing report sent from dev build: 

NetBeans Error Report Upload Complete
It has now been added to the database with id #538422. It has been classified as a duplicate of report #182453.
This bug was already fixed.
Please update your build of NetBeans to the latest build of 6.9 where bug #204506 is fixed. If you are already using a newer build and your report meets certain criteria a new bug will be filed automatically.
Thanks again for your help.

will investigate further.
Comment 3 Tomas Danek 2011-11-02 14:10:19 UTC
it turns out that reopen (submit new bug) works, however under following conditions:
1) reporter must not me GUEST
2) comment must not be empty

second one is not true in this case, therefor reopen did not happen. 
So i'll either remove check for second condition, or fix message if reopen does not happen.
Comment 4 Tomas Danek 2011-11-03 12:28:45 UTC
fixed. misc#f1590f73d593

- reopen happens also if there's report without comment from registered user.
- does not happen only for guest users; they are shown better message now.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo