Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 200183 - Customizer error/warning has no color
Customizer error/warning has no color
Status: RESOLVED INVALID
Product: platform
Classification: Unclassified
Component: Dialogs&Wizards
7.1
PC Linux
: P3 (vote)
: 7.1
Assigned To: Stanislav Aubrecht
issues@platform
: L&F, UI
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-16 08:12 UTC by Tomas Mysik
Modified: 2011-07-22 03:38 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
screenshot (32.75 KB, image/png)
2011-07-16 08:12 UTC, Tomas Mysik
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Mysik 2011-07-16 08:12:56 UTC
Created attachment 109465 [details]
screenshot

See attached screenshot.

Product Version: NetBeans IDE Dev (Build 20110715-47f8d9d37cc2)
Java: 1.6.0_24; Java HotSpot(TM) 64-Bit Server VM 19.1-b02
System: Linux version 2.6.38-10-generic running on amd64; UTF-8; cs_CZ (nb)
Comment 1 Jesse Glick 2011-07-18 13:07:44 UTC
UIManager.getColor("nb.errorForeground") is wrong sometimes on GTK. I think this is a duplicate of something but not sure.
Comment 2 Tomas Mysik 2011-07-18 15:41:48 UTC
Please notice that I don't have GTK L&F, I have the default one (Metal).

Also, I don't really think that this is a P4 since it is quite hard to discover that something is wrong if the panel is a bit more "full" (because the color is the same).

Thanks.
Comment 3 Stanislav Aubrecht 2011-07-21 13:43:56 UTC
- this has nothing to do with dialogs & wizard module. php project properties is based on CustomizerPanel from projectuiapi

- the screenshot shows that the Ok button is enabled, so the entered data are valid so there's no need for error color foreground
Comment 4 Tomas Mysik 2011-07-21 14:12:12 UTC
(In reply to comment #3)
> - this has nothing to do with dialogs & wizard module. php project properties
> is based on CustomizerPanel from projectuiapi

Right, I have reported it against Project UI (see history of this issue).

> - the screenshot shows that the Ok button is enabled, so the entered data are
> valid so there's no need for error color foreground

Right, it is not an error but a warning so I would expect some color specified for warning as well.

However, I don't plan to reopen this issue.
Comment 5 Stanislav Aubrecht 2011-07-21 14:18:18 UTC
default warning color is 'dark gray'

dialogs & wizard panels add error/warning icons to such messages, maybe project ui might do the same...
Comment 6 Tomas Mysik 2011-07-21 14:33:05 UTC
(In reply to comment #5)
> default warning color is 'dark gray'

Aha, then it's (kind of ;) OK.

> dialogs & wizard panels add error/warning icons to such messages, maybe project
> ui might do the same...

Good idea, I have reported it as issue #200289.

Thanks.
Comment 7 Jesse Glick 2011-07-22 00:30:21 UTC
*** Bug 200289 has been marked as a duplicate of this bug. ***
Comment 8 Jesse Glick 2011-07-22 00:42:42 UTC
(In reply to comment #5)
> default warning color is 'dark gray'

That is surprising. Warnings should be yellow.
Comment 9 Tomas Mysik 2011-07-22 03:38:19 UTC
(In reply to comment #8)
> That is surprising. Warnings should be yellow.

I have expected the same (or orange or similar). That's why I have reported this issue.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo