Bug 199734 - Java_ME_platform_SDK_3.0 is not detected
Java_ME_platform_SDK_3.0 is not detected
Status: VERIFIED FIXED
Product: javame
Classification: Unclassified
Component: -- Other --
7.1
PC Other
: P2 (vote)
: 7.0.1
Assigned To: Anton Chechel
issues@mobility
: 701_HR_FIX
: 199857 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-27 14:32 UTC by Anton Chechel
Modified: 2011-07-19 11:32 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Anton Chechel 2011-06-27 14:32:05 UTC
Product Version: NetBeans IDE 7.0 (Build 201104241500)
Java: 1.6.0_23; Java HotSpot(TM) 64-Bit Server VM 19.0-b09
System: Windows 7 version 6.1 running on amd64; Cp1252; en_US (nb)
Userdir: C:\Users\Manowar\.netbeans\7.0

Java_ME_platform_SDK_3.0 is not detected in add new Java Platform Wizard.
Caused by the fact that Java_ME_platform_SDK_3.0 is not working on Win7 x64 platform. Running bin/emulator.exe -XQuery returns nothing so NetBeans is not able to detect ME platform properties.
Comment 1 Anton Chechel 2011-06-27 14:54:52 UTC
Error log could be found here: userdir\\javame-sdk\\x.x\\log\\device-manager.log
Workaround: user should run ME SDK on JDK x86 architecture.

Fixed by adding message to detection panel: http://hg.netbeans.org/main/rev/b203b01bb21c
Comment 2 Anton Chechel 2011-06-27 15:11:16 UTC
transplanted into release701:
http://hg.netbeans.org/releases/rev/c705a232da1c
Comment 3 Anton Chechel 2011-07-02 10:57:55 UTC
*** Bug 199857 has been marked as a duplicate of this bug. ***
Comment 4 Stepan Zebra 2011-07-19 11:32:38 UTC
verified in 7.0.1 build 201107160900


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo