Bug 199669 - Select in Projects does not work if project not open
Select in Projects does not work if project not open
Status: VERIFIED FIXED
Product: projects
Classification: Unclassified
Component: Generic Projects UI
7.0
All All
: P3 (vote)
: 7.0.1
Assigned To: Jesse Glick
issues@projects
701patch1-verified
: REGRESSION
Depends on:
Blocks: 180155
  Show dependency treegraph
 
Reported: 2011-06-23 20:26 UTC by Jesse Glick
Modified: 2011-09-26 13:36 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2011-06-23 20:26:10 UTC
20110622-cfc30ee73061. If you Ctrl-1 on a file in a nonopen project and agree to open the project, the node does not get selected; you have to run the action again after the project is open.

Unclear when this was broken (not very recently); probably caused by some performance-related change in threading.
Comment 1 Jesse Glick 2011-06-23 20:39:22 UTC
core-main #b27a8d6038d3
Comment 2 Quality Engineering 2011-06-24 14:28:53 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/b27a8d6038d3
User: Jesse Glick <jglick@netbeans.org>
Log: #199669: Select in Projects does not work if project not open
Comment 3 Tomas Danek 2011-08-24 15:16:36 UTC
verified, works fine.

Product Version: NetBeans IDE Dev (Build 201108220601)
Java: 1.6.0_26; Java HotSpot(TM) 64-Bit Server VM 20.1-b02-384
System: Mac OS X version 10.6.8 running on x86_64; MacRoman; en_US (nb)
User directory: /Users/tomas/.netbeans/dev
Cache directory: /Users/tomas/.netbeans/dev/var/cache
Comment 4 Tomas Danek 2011-08-25 09:31:21 UTC
forgot to mark as VERIFIED
Comment 5 Jesse Glick 2011-08-25 16:11:22 UTC
releases #286846af5d94
Comment 6 Quality Engineering 2011-08-26 04:27:59 UTC
Integrated into 'releases'
Changeset: http://hg.netbeans.org/releases/rev/286846af5d94
User: Jesse Glick <jglick@netbeans.org>
Log: #199669: Select in Projects does not work if project not open
(transplanted from b27a8d6038d36c9beced597e4e95c4a13240391d)
Comment 7 Quality Engineering 2011-09-26 13:36:08 UTC
Integrated into 'releases'
Changeset: http://hg.netbeans.org/releases/rev/9ed980b7be67
User: Jesse Glick <jglick@netbeans.org>
Log: #199669: Select in Projects does not work if project not open
(transplanted from b27a8d6038d36c9beced597e4e95c4a13240391d)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo