Bug 199621 - Log4j class loading conflict on NB startup
Log4j class loading conflict on NB startup
Status: RESOLVED WONTFIX
Product: serverplugins
Classification: Unclassified
Component: JBoss
7.0
PC Windows XP x64
: P3 (vote)
: TBD
Assigned To: Petr Hejl
issues@serverplugins
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-22 13:49 UTC by lucabur
Modified: 2015-09-17 13:09 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
The ide log file (43.86 KB, text/plain)
2011-06-22 13:49 UTC, lucabur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description lucabur 2011-06-22 13:49:26 UTC
Created attachment 109054 [details]
The ide log file

Every time NB starts I find this message in the ide log file:
---
log4j:ERROR A "org.apache.log4j.RollingFileAppender" object is not assignable to a "org.apache.log4j.Appender" variable.
log4j:ERROR The class "org.apache.log4j.Appender" was loaded by 
log4j:ERROR [org.netbeans.modules.j2ee.jboss4.JBDeploymentFactory$JBClassLoader@5183093c] whereas object of type 
log4j:ERROR "org.apache.log4j.RollingFileAppender" was loaded by [ModuleCL@3bfc47[org.netbeans.modules.html.validation]].
log4j:ERROR Could not instantiate appender named "default".
log4j:ERROR A "org.apache.log4j.ConsoleAppender" object is not assignable to a "org.apache.log4j.Appender" variable.
log4j:ERROR The class "org.apache.log4j.Appender" was loaded by 
log4j:ERROR [org.netbeans.modules.j2ee.jboss4.JBDeploymentFactory$JBClassLoader@5183093c] whereas object of type 
log4j:ERROR "org.apache.log4j.ConsoleAppender" was loaded by [ModuleCL@3bfc47[org.netbeans.modules.html.validation]].
log4j:ERROR Could not instantiate appender named "stdout".
log4j:WARN No appenders could be found for logger (org.jboss.deployment.spi.factories.DeploymentFactoryImpl).
log4j:WARN Please initialize the log4j system properly.
---
Comment 1 Petr Jiricka 2011-10-05 13:15:52 UTC
Looks like some kind of a conflict between the HTML functionality and the JBoss plugin - although I can not reproduce on my machine. Petr and Marek, can you please investigate?
Comment 2 Martin Balin 2015-09-17 13:09:55 UTC
Report from old NetBeans version. Due to code changes since it was reported likely not reproducible now. Feel free to reopen if happens in 8.0.2 or 8.1.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo