Bug 199618 - Code Complete Problem
Code Complete Problem
Product: javaee
Classification: Unclassified
Component: Expression Language
PC Windows XP
: P3 (vote)
: 8.0.1
Assigned To: Martin Fousek
Depends on:
  Show dependency treegraph
Reported: 2011-06-22 12:56 UTC by jpcotrim
Modified: 2014-07-29 14:33 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT


Note You need to log in before you can comment on or make changes to this bug.
Description jpcotrim 2011-06-22 12:56:00 UTC
In netbeans 6.9.1 code complete for jsp:useBean works fine, in netbeans 7.1 it stopped working. I am trying to ctrl-space and the attributes don't appear anymore, tks.
Comment 1 jpcotrim 2011-06-22 12:58:13 UTC
The code complete doesn´t work for the "beans" attributes like a  ClientBean.getName method, the "bean.name" doesn't appear in jsp (ctrl space).
Comment 2 Petr Jiricka 2011-06-22 15:17:56 UTC
I was testing this today and it more or less works for me, though I also found some weird behavior. Can you describe your case exactly? Are you trying to complete some attribute of jsp:useBean itself? Or some attribute of jsp:getProperty? Or something else?

I tried the following:
1. Completion for 'class' attribute of jsp:useBean - works if you specify some package prefix (completes the rest)
2. Completion for 'name' attribute of jsp:getProperty - works, offers beans that are defined in this page using jsp:useBean
3. Completion for 'property' attribute of jsp:getProperty - works, but your project needs to be built (JSP parser uses binary artefacts to inspect the bean. Sometimes there are problems with the list not being up to date - restarting the IDE worked around this problem.

So based on the above, and I don't see this as a P1 problem, adjusting priority to P3. I agree this is a bug.
Comment 3 Petr Jiricka 2011-06-24 08:27:52 UTC
Got more info privately from the reporter - he says this is a regression and it worked in 6.9.1:

"The problem i am facing on netbeans 7.0 happens when i create a class with an attribute, then i try 
to find this attribute with ctrl space in jsp. I created a client class with a propertie name, and a method
getName(), in netbeans 6.9.1 when i press ctrl + space after typing "client." the propertie name 
appears for selection in jsp (using expression language, for jsp:useBean client, like ${client.name}), 
but on netbeans 7.0, it isn't working anymore, the ${client.anything} do not appear any more. 
Well, again, sorry for my bad english and the problem you commented really happens, but with 
ide restarting works fine, but the problem i am facing, even with netbeans restart don't resolves."
Comment 4 Marek Fukala 2014-07-29 10:09:34 UTC
I'm not sure what exactly the user tries to do, but it looks like he complains about hyperlinking in EL expressions not working for his bean properties.
Comment 5 Martin Fousek 2014-07-29 14:33:24 UTC
I'm not able to reproduce the issue. Reporter please feel free to reopen it with additional information of your project setup - ideally any sample bean you are complaining about. All navigations I tried with properties of beans declared using useBean tag worked well to me.

By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo