Bug 199615 - Secondary source root in free-form library is ignored
Secondary source root in free-form library is ignored
Status: VERIFIED WONTFIX
Product: java
Classification: Unclassified
Component: Freeform
7.0.1
PC Windows XP
: P4 (vote)
: TBD
Assigned To: Tomas Zezula
issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-22 11:35 UTC by Jiri Skrivanek
Modified: 2016-07-07 08:43 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Projects for test. (18.03 KB, application/zip)
2011-06-22 11:35 UTC, Jiri Skrivanek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Skrivanek 2011-06-22 11:35:42 UTC
Created attachment 109048 [details]
Projects for test.

Classes from secondary source root in free-form library are ignored in main application. To reproduce:

- open attached projects
- open MainApp.java. Class Divider should be known but it is declared as missing. If you try to compile from command-line, it works (ant -f MainApp/build.xml).

Product Version: NetBeans IDE 7.0.1 RC1 (Build 201106212100)
Java: 1.7.0; Java HotSpot(TM) Client VM 21.0-b16
System: Windows XP version 5.1 running on x86; Cp1250; en_US (nb)
Comment 1 Jan Lahoda 2011-10-17 08:56:28 UTC
The problem is that the freeform does not bind src2 with the resulting jar (via <built-to>dist/TestFreeformLibrary.jar</built-to>). After this is corrected, the dependencies work correctly. However, the freeform does not appear to fire the correct events, so that a restart is required (->P4).
Comment 2 Martin Balin 2016-07-07 07:16:10 UTC
This old bug may not be relevant anymore. If you can still reproduce it in 8.2 development builds please reopen this issue.

Thanks for your cooperation,
NetBeans IDE 8.2 Release Boss


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo