Bug 199497 - IDE hang
IDE hang
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Filesystems
7.0
PC Solaris
: P1 (vote)
: 7.0.1
Assigned To: Egor Ushakov
issues@platform
701patch1-fixed
:
: 200070 200989 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-17 12:24 UTC by Egor Ushakov
Modified: 2011-08-18 14:50 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
thread dump (31.94 KB, text/plain)
2011-06-17 12:24 UTC, Egor Ushakov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Egor Ushakov 2011-06-17 12:24:48 UTC
Created attachment 108955 [details]
thread dump

IDE just hangs, see thread dump attached
Comment 1 Egor Ushakov 2011-06-17 12:26:13 UTC
It looks like FAMMonitorDirectory hangs, but it did not happen before.
Has anything changed in the way watches added recently?
Comment 2 Jaroslav Tulach 2011-06-27 06:55:12 UTC
Fix for issue 197985 the Notifiers are used more often then in 7.0.x. Maybe this is causing problems for the FAM implementation. As most of the code was written by gorrus, passing to him.
Comment 3 Egor Ushakov 2011-06-27 16:28:46 UTC
IDE always hangs on Solaris after some time, but only in trunk, so this is NOT a showstopper for 7.0.l
Comment 4 Egor Ushakov 2011-06-28 09:08:54 UTC
indeed it looks like a showstopper for 7.0.1:
I've done some tests and it looks like FAMNotifier hangs on new addWatch after 700-800 watches added. Recent changes only made this hang appear faster.
Comment 5 Alexander Pepin 2011-06-28 09:28:38 UTC
I agree. Please follow the showstopper process.
Comment 6 Egor Ushakov 2011-06-28 10:29:12 UTC
nextEvent is reading FAM events too slow (one per second) and after some time FAM buffer gets full and then it blocks everything
Comment 7 Egor Ushakov 2011-06-28 16:46:27 UTC
After fixes (in trunk) findMIMEType is creating and destroying way too many CachedFileObject and it produces enormous number of Notifier add/remove watch requests. FAM implementation has a bug that prevents it from working if input buffer was overflown. I'll think about a workaround on java side.
At the same time it would be great if findMIMEType did not produce so many Notifier requests if possible.
I'm sure it should not be a problem for 7.0.1.
Comment 8 Egor Ushakov 2011-06-30 08:40:36 UTC
fixed in:
http://hg.netbeans.org/cnd-main/rev/f346f41394ac

this fix limits the number of unprocessed FAM requests to 100 and blocks the next request until FAM gets less busy. This will lead to slowdown reports which must be fixed by reducing the number of watcher requests from findMIMEType
Comment 9 Quality Engineering 2011-07-01 14:07:04 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/f346f41394ac
User: Egor Ushakov <gorrus@netbeans.org>
Log: fixed #199497 (IDE hang)
Comment 10 Egor Ushakov 2011-08-18 14:37:16 UTC
*** Bug 200989 has been marked as a duplicate of this bug. ***
Comment 11 Egor Ushakov 2011-08-18 14:38:27 UTC
fix was verified by the reporter of the #200989 in dev build
Comment 12 Egor Ushakov 2011-08-18 14:40:22 UTC
*** Bug 200070 has been marked as a duplicate of this bug. ***
Comment 13 Egor Ushakov 2011-08-18 14:49:52 UTC
integrated into release701_fixes:
http://hg.netbeans.org/releases/rev/5fb14aaed317


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo