Bug 199488 - CodeCompletion took 3203 ms.
CodeCompletion took 3203 ms.
Status: RESOLVED DUPLICATE of bug 200332
Product: java
Classification: Unclassified
Component: Editor
7.0
All All
: P3 (vote)
: TBD
Assigned To: Dusan Balek
issues@java
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-17 07:14 UTC by jmichelberger
Modified: 2011-10-20 14:44 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (19.02 KB, application/nps)
2011-06-17 07:14 UTC, jmichelberger
Details
nps snapshot (78.52 KB, application/nps)
2011-07-04 02:52 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jmichelberger 2011-06-17 07:14:48 UTC
Build: NetBeans IDE 7.0 (Build 201105291501)
VM: Java HotSpot(TM) Client VM, 20.1-b02, Java(TM) SE Runtime Environment, 1.6.0_26-b03
OS: Windows XP

User Comments:
jtulach: I really don't know what the system is waiting for...

GUEST: Just added XStream to my project and was attempting to instantiate one of the XStream classes



Maximum slowness yet reported was 6743 ms, average is 3449
Comment 1 jmichelberger 2011-06-17 07:14:54 UTC
Created attachment 108946 [details]
nps snapshot
Comment 2 Exceptions Reporter 2011-07-04 02:52:48 UTC
Created attachment 109220 [details]
nps snapshot
Comment 3 Dusan Balek 2011-10-20 14:44:02 UTC
Sorry - no code completion is available while 'Scanning Projects'. Code
completion has nothing to diplay until the up-to-date project metadata are
collected. "Scanning in progress..." message should be displayed in the code
completion popup requesting user to wait.

*** This bug has been marked as a duplicate of bug 200332 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo