Bug 199340 - Editor is not fully focused (disappearing cursor)
Editor is not fully focused (disappearing cursor)
Status: CLOSED WONTFIX
Product: editor
Classification: Unclassified
Component: Painting & Printing
7.0
PC Linux
: P2 (vote)
: 7.0.1
Assigned To: Miloslav Metelka
issues@editor
jdk_bug_7066513
: 7.0.1_WAIVER_APPROVED, FOCUS, JDK_1.7
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-10 15:26 UTC by Jiri Kovalsky
Modified: 2011-07-18 08:39 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Kovalsky 2011-06-10 15:26:16 UTC
Product Version: NetBeans IDE 7.0.1 Dev (Build 201106072116)
Java: 1.7.0-ea; Java HotSpot(TM) 64-Bit Server VM 21.0-b15
System: Linux version 2.6.35-22-generic running on amd64; UTF-8; cs_CZ (nb)
Userdir: /home/cesilko/.netbeans/7.0.1dev

If you edit some file, invoke for example New Breakpoint dialog and then cancel it, the cursor does not appear again. It is not possible to select lines by Shift + Arrows etc. The workaround is to focus Explorer and then back Editor. This will display cursor again. Please note this works fine with JDK 6 Update 26.

Steps to reproduce:
===================
1. Generate Anagram Game sample Java application.
2. Open Anagrams.java file and press Ctrl+Shift+F8.
3. When "New Breakpoint" dialog opens, just hit Esc.
4. Dialog will get closed and Editor will receive focus but there will be no cursor visible.
Comment 1 Miloslav Metelka 2011-06-22 14:00:36 UTC
I've just tested on b146 of JDK7 and it seems to work fine:

NetBeans IDE 7.0.1 RC1 (Build 20110622-ca4a6a462006) (#ca4a6a462006)
Linux version 2.6.35-28-generic running on amd64
1.7.0; Java HotSpot(TM) 64-Bit Server VM 21.0-b16; Oracle Corporation
Java(TM) SE Runtime Environment 1.7.0-b146

Marking as worksforme please Jirko (and possibly QE too) verify that it's ok. Thanks.
Comment 2 Jiri Kovalsky 2011-06-23 13:03:26 UTC
I am sorry Milo but I can still reproduce it in:

Product Version: NetBeans IDE 7.0.1 RC1 (Build 201106222100)
Java: 1.7.0; Java HotSpot(TM) 64-Bit Server VM 21.0-b16
System: Linux version 2.6.35-22-generic running on amd64; UTF-8; cs_CZ (nb)
Userdir: /home/cesilko/.netbeans/7.0.1rc1

This is not candid Ubuntu though. If it matters I use Linux Mint 10 (Julia) which is based on Ubuntu 10. If you want, I can show you the bug next Monday - 6/27 when I will be in the office in person.
Comment 3 Jiri Kovalsky 2011-07-13 12:34:01 UTC
Since it's reproducible with SwingSet2 demo too I reported it against JDK itself:

http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=7066513


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo