Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 199294 - [70cat] NoSuchMethodError: org.netbeans.modules.css.formatting.api.embedding.JoinedTokenSequence.index()I
[70cat] NoSuchMethodError: org.netbeans.modules.css.formatting.api.embedding....
Status: RESOLVED DUPLICATE of bug 197605
Product: javaee
Classification: Unclassified
Component: JSP
7.0
All All
: P3 (vote)
: 7.1
Assigned To: issues@javaee
issues@javaee
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-09 01:54 UTC by alied
Modified: 2011-10-26 06:07 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (9.12 KB, text/plain)
2011-06-09 01:54 UTC, alied
Details

Note You need to log in before you can comment on or make changes to this bug.
Description alied 2011-06-09 01:54:06 UTC
Build: NetBeans IDE 7.0.1 Dev (Build 201106020000)
VM: Java HotSpot(TM) 64-Bit Server VM, 21.0-b14, Java(TM) SE Runtime Environment, 1.7.0-ea-b144
OS: Linux

User Comments:
bitray: create a web project

alied: Following the "Creating an Enterprise Application with EJB 3.1" tutorial[1], just after pressing Finish.

[1]http://netbeans.org/kb/docs/javaee/javaee-entapp-ejb.html




Stacktrace: 
java.lang.NoSuchMethodError: org.netbeans.modules.css.formatting.api.embedding.JoinedTokenSequence.index()I
   at org.netbeans.modules.web.core.syntax.formatting.JspIndenter.getPreservedLineInitialIndentation(JspIndenter.java:163)
   at org.netbeans.modules.css.formatting.api.support.MarkupAbstractIndenter.getLineIndent(MarkupAbstractIndenter.java:485)
   at org.netbeans.modules.css.formatting.api.support.AbstractIndenter.processLanguage(AbstractIndenter.java:1188)
   at org.netbeans.modules.css.formatting.api.support.AbstractIndenter.calculateIndentation(AbstractIndenter.java:345)
   at org.netbeans.modules.css.formatting.api.support.AbstractIndenter.reindent(AbstractIndenter.java:209)
   at org.netbeans.modules.web.core.syntax.indent.JspIndentTask.reindent(JspIndentTask.java:59)
Comment 1 alied 2011-06-09 01:54:11 UTC
Created attachment 108815 [details]
stacktrace
Comment 2 alied 2011-06-09 03:20:04 UTC
The enterprise Project gets created, but the EJB and the web projects don't
Comment 3 alied 2011-06-09 03:21:42 UTC
system info:
Product Version: NetBeans IDE 7.0.1 Dev (Build 201106020000)
Java: 1.7.0-ea; Java HotSpot(TM) 64-Bit Server VM 21.0-b14
System: Linux version 2.6.39 running on amd64; UTF-8; es_AR (nb)(SMP-enabled)
Comment 4 Exceptions Reporter 2011-08-24 15:29:23 UTC
This bug already has 5 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=178245
Comment 5 BadboyBoogey 2011-09-16 12:16:05 UTC
Only when Create Web Application Module check box is selected.

java.lang.NoSuchMethodError: org.netbeans.modules.css.formatting.api.embedding.JoinedTokenSequence.index()I
	at org.netbeans.modules.web.core.syntax.formatting.JspIndenter.getPreservedLineInitialIndentation(JspIndenter.java:163)
	at org.netbeans.modules.css.formatting.api.support.MarkupAbstractIndenter.getLineIndent(MarkupAbstractIndenter.java:485)
	at org.netbeans.modules.css.formatting.api.support.AbstractIndenter.processLanguage(AbstractIndenter.java:1188)
	at org.netbeans.modules.css.formatting.api.support.AbstractIndenter.calculateIndentation(AbstractIndenter.java:345)
	at org.netbeans.modules.css.formatting.api.support.AbstractIndenter.reindent(AbstractIndenter.java:209)
	at org.netbeans.modules.web.core.syntax.indent.JspIndentTask.reindent(JspIndentTask.java:59)
	at org.netbeans.modules.editor.indent.TaskHandler$MimeItem.runTask(TaskHandler.java:546)
	at org.netbeans.modules.editor.indent.TaskHandler.runTasks(TaskHandler.java:316)
	at org.netbeans.modules.editor.indent.IndentImpl.reformat(IndentImpl.java:357)
	at org.netbeans.modules.editor.indent.api.Reformat.reformat(Reformat.java:154)
	at org.netbeans.editor.ActionFactory.reformat(ActionFactory.java:1755)
	at org.netbeans.editor.BaseDocument$Accessor.ActionFactory_reformat(BaseDocument.java:2559)
	at org.netbeans.modules.editor.EditorModule$8.run(EditorModule.java:673)
	at org.netbeans.editor.GuardedDocument.runAtomicAsUser(GuardedDocument.java:344)
	at org.openide.text.NbDocument.runAtomicAsUser(NbDocument.java:448)
	at org.netbeans.modules.editor.EditorModule.reformat(EditorModule.java:667)
	at org.netbeans.modules.editor.EditorModule.access$100(EditorModule.java:106)
	at org.netbeans.modules.editor.EditorModule$6.operationCreateFromTemplate(EditorModule.java:352)
	at org.openide.loaders.DataLoaderPool.fireOperationEvent(DataLoaderPool.java:240)
	at org.openide.loaders.DataObject.fireOperationEvent(DataObject.java:848)
	at org.openide.loaders.DataObject.createFromTemplate(DataObject.java:821)
	at org.openide.loaders.DataObject.createFromTemplate(DataObject.java:800)
	at org.netbeans.modules.web.project.api.WebProjectUtilities.createIndexJSP(WebProjectUtilities.java:384)
	at org.netbeans.modules.web.project.api.WebProjectUtilities.ensureWelcomePage(WebProjectUtilities.java:347)
	at org.netbeans.modules.j2ee.earproject.ui.wizards.NewEarProjectWizardIterator.testableInstantiate(NewEarProjectWizardIterator.java:233)
	at org.netbeans.modules.j2ee.earproject.ui.wizards.NewEarProjectWizardIterator.instantiate(NewEarProjectWizardIterator.java:165)
	at org.openide.loaders.TemplateWizard$InstantiatingIteratorBridge.instantiate(TemplateWizard.java:1019)
	at org.openide.loaders.TemplateWizard.handleInstantiate(TemplateWizard.java:591)
	at org.openide.loaders.TemplateWizard.instantiateNewObjects(TemplateWizard.java:412)
	at org.openide.loaders.TemplateWizardIterImpl.instantiate(TemplateWizardIterImpl.java:256)
	at org.openide.loaders.TemplateWizardIteratorWrapper.instantiate(TemplateWizardIteratorWrapper.java:168)
	at org.openide.WizardDescriptor.callInstantiateOpen(WizardDescriptor.java:1548)
	at org.openide.WizardDescriptor.callInstantiate(WizardDescriptor.java:1505)
	at org.openide.WizardDescriptor.access$1700(WizardDescriptor.java:137)
	at org.openide.WizardDescriptor$Listener$2$1.run(WizardDescriptor.java:2099)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1424)
[catch] at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:1968
Comment 6 Martin Fousek 2011-10-26 06:07:23 UTC

*** This bug has been marked as a duplicate of bug 197605 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo