Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 199261 - Missing help window for built-in identifiers ($GLOBAL etc.)
Missing help window for built-in identifiers ($GLOBAL etc.)
Status: VERIFIED WORKSFORME
Product: php
Classification: Unclassified
Component: Editor
7.0
PC Windows XP
: P3 (vote)
: 7.1
Assigned To: Ondrej Brejla
issues@php
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-08 11:29 UTC by Vladimir Riha
Modified: 2011-10-10 08:07 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
screenshot (5.67 KB, image/png)
2011-06-20 09:31 UTC, Vladimir Riha
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Riha 2011-06-08 11:29:41 UTC
In php file (or web page), invoke code completion at blank line and focus (simply using arrow button) for example $GLOBAL, help window should appear, but it isn't.

Product Version: NetBeans IDE 7.0.1 Dev (Build 201106072116)
Java: 1.7.0-ea; Java HotSpot(TM) Client VM 21.0-b15
System: Windows XP version 5.1 running on x86; Cp1252; en_US (nb)
Comment 1 Vladimir Riha 2011-06-14 15:21:12 UTC
fyi, this works on Linux...
Comment 2 Petr Pisl 2011-06-16 08:41:22 UTC
Hmm, strange I can not reproduce on my winXP box in virtualbox. For the runtime function it works for you?
Comment 3 Vladimir Riha 2011-06-20 09:31:55 UTC
Created attachment 108987 [details]
screenshot

I'm not sure what is a runtime function but for example help for imap_alerts() works. I also tried to define some simple function and add some documentation to it and it works. When I used CC and focused the function, help window opened. (In this and the previous case I used a new user dir).

The help windows is not displayed for items between $GLOBALS and $php_errormsg (see the screenshot)

Product Version: NetBeans IDE 7.0.1 Dev (Build 201106192100)
Java: 1.7.0-ea; Java HotSpot(TM) Client VM 21.0-b15
System: Windows XP version 5.1 running on x86; Cp1252; en_US (nb)
Comment 4 Ondrej Brejla 2011-08-31 09:10:01 UTC
Vlado, can you try it in NB 7.1 dev? Thanks
Comment 5 Ondrej Brejla 2011-08-31 09:11:17 UTC
cc
Comment 6 Vladimir Riha 2011-09-01 08:39:26 UTC
Yes, it works in latest dev build as expected
Comment 7 Ondrej Brejla 2011-09-01 08:48:07 UTC
Ok -> works for me.
Comment 8 Vladimir Riha 2011-10-10 08:07:05 UTC
v.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo