Bug 199241 - NullPointerException at org.netbeans.modules.project.uiapi.DefaultProjectOperationsImplementation.computeError
NullPointerException at org.netbeans.modules.project.uiapi.DefaultProjectOper...
Status: VERIFIED FIXED
Product: projects
Classification: Unclassified
Component: Generic Infrastructure
7.0
All All
: P3 (vote)
: 7.0.1
Assigned To: Jesse Glick
issues@projects
EXCEPTIONS_REPORT 701patch1-verified
:
: 201136 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-07 16:18 UTC by Alexander Simon
Modified: 2011-09-26 13:28 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (4.00 KB, text/plain)
2011-06-07 16:18 UTC, Alexander Simon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Simon 2011-06-07 16:18:45 UTC
Build: NetBeans IDE 7.0.1 Dev (Build 20110607-8df63e2eccad)
VM: Java HotSpot(TM) 64-Bit Server VM, 19.1-b02, Java(TM) SE Runtime Environment, 1.6.0_24-b07
OS: Linux

User Comments:
alexvsimon: Cannot rename full remote project.
Caused by method:
DefaultProjectRenamePanel.computeError()
Method convertes project file object to file.
Full remote project does not have java.io.File under FileObject

GUEST: Sanning a new projec on a local network comuter

GUEST: I was trying to rename a PHP Project Folder. The action: Right click on Project > Rename




Stacktrace: 
java.lang.NullPointerException
   at org.netbeans.modules.project.uiapi.DefaultProjectOperationsImplementation.computeError(DefaultProjectOperationsImplementation.java:691)
   at org.netbeans.modules.project.uiapi.DefaultProjectOperationsImplementation.computeError(DefaultProjectOperationsImplementation.java:686)
   at org.netbeans.modules.project.uiapi.DefaultProjectRenamePanel.computeError(DefaultProjectRenamePanel.java:311)
   at org.netbeans.modules.project.uiapi.DefaultProjectRenamePanel.validateDialog(DefaultProjectRenamePanel.java:294)
   at org.netbeans.modules.project.uiapi.DefaultProjectRenamePanel.<init>(DefaultProjectRenamePanel.java:85)
   at org.netbeans.modules.project.uiapi.DefaultProjectOperationsImplementation.renameProject(DefaultProjectOperationsImplementation.java:348)
Comment 1 Alexander Simon 2011-06-07 16:18:49 UTC
Created attachment 108784 [details]
stacktrace
Comment 2 Jesse Glick 2011-06-07 19:50:38 UTC
core-main #4fb6b40d3434
Comment 3 Quality Engineering 2011-06-08 14:49:33 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/4fb6b40d3434
User: Jesse Glick <jglick@netbeans.org>
Log: #199241: NullPointerException at org.netbeans.modules.project.uiapi.DefaultProjectOperationsImplementation.computeError
A fuller but riskier fix would be to take URL, and replace File.exists by URLMapper.findFileObject(...) != null.
Not clear that this level of prevalidation is even desirable for remote projects.
Comment 4 Jesse Glick 2011-08-22 22:57:24 UTC
*** Bug 201136 has been marked as a duplicate of this bug. ***
Comment 5 Alexander Simon 2011-08-23 07:38:42 UTC
fix transplanted in release701_fixes branch on http://elif.russia.sun.com/hg/releases_elif for verifying:
4fb6b40d3434 transplanted to 0eadfa7df0c9
Comment 6 Alexander Simon 2011-08-23 08:51:54 UTC
fix dependency in release701_fixes: 
http://elif.russia.sun.com/hg/releases_elif/rev/585dcfe78f97
Comment 7 dnikitin 2011-08-23 09:56:45 UTC
verified in NetBeans IDE 7.0.1 (Build oss-platform-build-30-on-20110823)
Comment 8 dnikitin 2011-08-23 12:09:07 UTC
Opps. 701patch1_fixed rather than *_verified
Comment 9 Alexander Simon 2011-08-24 11:48:14 UTC
integrated in release701_fixes:
0eadfa7df0c9 transplanted to 4d25aa36af96
585dcfe78f97 transplanted to 6ba56faf45fa
Comment 10 Quality Engineering 2011-08-25 04:26:35 UTC
Integrated into 'releases'
Changeset: http://hg.netbeans.org/releases/rev/4d25aa36af96
User: Jesse Glick <jglick@netbeans.org>
Log: #199241: NullPointerException at org.netbeans.modules.project.uiapi.DefaultProjectOperationsImplementation.computeError
A fuller but riskier fix would be to take URL, and replace File.exists by URLMapper.findFileObject(...) != null.
Not clear that this level of prevalidation is even desirable for remote projects.
(transplanted from 0eadfa7df0c957b6c0963416a20b3139bfb618d4)
Comment 11 dnikitin 2011-08-29 12:53:04 UTC
verified in 7.0.1 patch1
Comment 12 Quality Engineering 2011-09-26 13:28:02 UTC
Integrated into 'releases'
Changeset: http://hg.netbeans.org/releases/rev/0eadfa7df0c9
User: Jesse Glick <jglick@netbeans.org>
Log: #199241: NullPointerException at org.netbeans.modules.project.uiapi.DefaultProjectOperationsImplementation.computeError
A fuller but riskier fix would be to take URL, and replace File.exists by URLMapper.findFileObject(...) != null.
Not clear that this level of prevalidation is even desirable for remote projects.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo