Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 199210 - Remote server certificate not stored
Remote server certificate not stored
Status: RESOLVED FIXED
Product: versioncontrol
Classification: Unclassified
Component: Subversion
7.0
PC Windows XP
: P3 (vote)
: 7.1
Assigned To: Ondrej Vrabec
issues@versioncontrol
:
: 201284 205763 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-06 18:39 UTC by javydreamercsw
Modified: 2012-01-10 21:17 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Requested logs after clicking accept permanently (49.19 KB, application/octet-stream)
2011-07-01 13:16 UTC, javydreamercsw
Details
IDE Log after 'accept permanently' [Ubuntu 10.10 NetBeans 7.0.1] (27.26 KB, text/plain)
2011-08-25 15:11 UTC, d-man97
Details

Note You need to log in before you can comment on or make changes to this bug.
Description javydreamercsw 2011-06-06 18:39:58 UTC
Each time I start up the IDE and try to do a subversion operation it asks about the certificate not available. I select accept permanently but it only lasts the current session. It works fine on 7.0.
Comment 1 Ondrej Vrabec 2011-06-10 13:22:52 UTC
Attach the message log after you clicked on Accept Permanently
Comment 2 javydreamercsw 2011-07-01 13:16:59 UTC
Created attachment 109190 [details]
Requested logs after clicking accept permanently
Comment 3 mdm42 2011-08-03 13:40:58 UTC
Same issue on Linux:

INFO [org.netbeans.modules.subversion]
org.ini4j.InvalidFileFormatException: parse error (at line: 75): *.rej *~ #*# .#* .*.swp .DS_Store
        at org.ini4j.spi.AbstractParser.parseError(AbstractParser.java:53)
        at org.ini4j.spi.AbstractParser.parseOptionLine(AbstractParser.java:85)
        at org.ini4j.spi.IniParser.parse(IniParser.java:101)
        at org.ini4j.spi.IniParser.parse(IniParser.java:62)
        at org.ini4j.Ini.load(Ini.java:109)
        at org.ini4j.Ini.<init>(Ini.java:50)
[catch] at org.netbeans.modules.subversion.config.SvnConfigFiles.loadSystemIniFile(SvnConfigFiles.java:537)
        at org.netbeans.modules.subversion.config.SvnConfigFiles.copyConfigFileToIDEConfigDir(SvnConfigFiles.j
ava:496)
        at org.netbeans.modules.subversion.config.SvnConfigFiles.<init>(SvnConfigFiles.java:143)
        at org.netbeans.modules.subversion.config.SvnConfigFiles.getInstance(SvnConfigFiles.java:166)
        at org.netbeans.modules.subversion.client.SvnClientFactory.setup(SvnClientFactory.java:199)
        at org.netbeans.modules.subversion.client.SvnClientFactory.init(SvnClientFactory.java:114)
        at org.netbeans.modules.subversion.Annotator$1.run(Annotator.java:666)
        at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1424)
        at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:1968)
WARNING [org.netbeans.modules.subversion]: Could not load the file /home/mike/.subversion//config. Falling bac
k on svn defaults.
INFO [org.netbeans.libs.svnclientadapter]: Javahl client adapter is not available
Failed to load JavaHL Library.
These are the errors that were encountered:
no libsvnjavahl-1 in java.library.path
no svnjavahl-1 in java.library.path
no svnjavahl in java.library.path
java.library.path = /opt/jdk1.6.0_26/jre/lib/i386/client:/opt/jdk1.6.0_26/jre/lib/i386:/opt/jdk1.6.0_26/jre/..
/lib/i386:/usr/java/packages/lib/i386:/lib:/usr/lib
INFO [org.netbeans.modules.subversion.client.SvnClientFactory]: JavaHL not available. Falling back on SvnKit.
INFO [org.netbeans.modules.subversion.client.SvnClientFactory]: svnClientAdapter running on svnkit
Comment 4 Ondrej Vrabec 2011-08-03 13:45:33 UTC
(In reply to comment #3)
> Same issue on Linux:
> 
> INFO [org.netbeans.modules.subversion]
> org.ini4j.InvalidFileFormatException: parse error (at line: 75): *.rej *~ #*#
> .#* .*.swp .DS_Store
Probably crlf issue in ~/.subversion/config ? Try to fix line 75
Comment 5 Ondrej Vrabec 2011-08-25 06:35:07 UTC
*** Bug 201284 has been marked as a duplicate of this bug. ***
Comment 6 d-man97 2011-08-25 15:11:40 UTC
Created attachment 110215 [details]
IDE Log after 'accept permanently' [Ubuntu 10.10 NetBeans 7.0.1]

No noticeable errors in the log. Removed the trailing new line from ~/.subversion/config and re-entered the newlines around the 1 line I manually added to the file ("*.php = svn:keywords=Id").

Restarted NetBeans - still have to accept.
Restarted NetBeans again - still have to accept.
Comment 7 Ondrej Vrabec 2011-08-29 16:27:27 UTC
fix: http://hg.netbeans.org/core-main/rev/75a5416eb167
Comment 8 Quality Engineering 2011-08-30 14:22:18 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/75a5416eb167
User: Ondrej Vrabec <ovrabec@netbeans.org>
Log: #199210 - Remote server certificate not stored
server certificates may be stored, passwords may not
Comment 9 Ondrej Vrabec 2011-12-01 10:20:33 UTC
*** Bug 205763 has been marked as a duplicate of this bug. ***
Comment 10 d-man97 2012-01-10 21:17:40 UTC
Thank you ovrabec! Working fine in 7.1 - you have gotten rid of one of my last "annoyances" with NetBeans.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo