Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 199194 - Handling of javadoc generated by (Open)JDK1.7
Handling of javadoc generated by (Open)JDK1.7
Status: VERIFIED FIXED
Product: editor
Classification: Unclassified
Component: Hints & Annotations
7.0.1
PC Windows XP
: P2 (vote)
: 7.0.1
Assigned To: Jan Lahoda
issues@editor
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-06 14:02 UTC by javydreamercsw
Modified: 2011-06-23 09:26 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
logs (1.35 MB, text/plain)
2011-06-06 14:02 UTC, javydreamercsw
Details

Note You need to log in before you can comment on or make changes to this bug.
Description javydreamercsw 2011-06-06 14:02:54 UTC
Created attachment 108754 [details]
logs

I got lots of warning in the log. The error badge was displayed in the status bar (bottom right corner). When I clicked to report from IDE the report screen was empty. After restart everything worked fine and has ever since.
Comment 1 Quality Engineering 2011-06-16 19:58:08 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/cdba185ee45a
User: Jan Lahoda <jlahoda@netbeans.org>
Log: #199194: handling javadoc generated by (Open)JDK1.7.
Comment 2 Jan Lahoda 2011-06-17 13:54:19 UTC
The most important exception from the log (IMO) are:
-the IOException from the HTML javadoc: although this is printed only into the log, Javadoc does not work for affected classes. Should be fixed by the above commit. I would like to ask QE for verification of this, so to allow propagation to release701. Can be reproduced by showing javadoc for System.err.println. Note that the platform must *not* contain sources, because sources are always preferred to javadocs.
-two kinds exceptions from cnd - already filled as bug #164497 and bug #197491 (these are likely showing the red one-way icon).
Comment 3 Jan Lahoda 2011-06-22 12:07:26 UTC
QE, could you please test the fix for the javadoc handling (see above)? Dusan, could you please review the fix? Thanks.
Comment 4 Dusan Balek 2011-06-22 12:52:19 UTC
The fix seems to be OK.
Comment 5 Stepan Zebra 2011-06-22 13:58:14 UTC
Product Version: NetBeans IDE Dev (Build 201106200600)
Java: 1.7.0; Java HotSpot(TM) Client VM 21.0-b16
System: Windows XP version 5.1 running on x86; Cp1252; en_US (nb)

Verified in trunk, approving integration into release701 branch.
Comment 6 Jan Lahoda 2011-06-22 15:07:58 UTC
Thanks. Transplanted to release701:
http://hg.netbeans.org/releases/rev/aadfba9798ea
Comment 7 Quality Engineering 2011-06-23 04:42:49 UTC
Integrated into 'releases'
Changeset: http://hg.netbeans.org/releases/rev/aadfba9798ea
User: Jan Lahoda <jlahoda@netbeans.org>
Log: #199194: handling javadoc generated by (Open)JDK1.7.
Comment 8 Stepan Zebra 2011-06-23 09:26:32 UTC
Product Version: NetBeans IDE 7.0.1 RC1 (Build 201106222100)
Java: 1.7.0; Java HotSpot(TM) Client VM 21.0-b16
System: Windows XP version 5.1 running on x86; Cp1252; en_US (nb)

Verified in release701.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo