Bug 199162 - Menus do not stick when the IDE is in maximized mode
Menus do not stick when the IDE is in maximized mode
Status: RESOLVED DUPLICATE of bug 198639
Product: platform
Classification: Unclassified
Component: Window System
7.0
All Linux
: P3 (vote)
: TBD
Assigned To: Stanislav Aubrecht
issues@platform
: PLATFORM
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-04 12:42 UTC by hknust
Modified: 2011-09-06 13:59 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description hknust 2011-06-04 12:42:57 UTC
Product Version = NetBeans IDE 7.0 (Build 201104080000)
Operating System = Linux version 2.6.38.6-27.fc15.x86_64 running on amd64
Java; VM; Vendor = 1.6.0_25
Runtime = Java HotSpot(TM) 64-Bit Server VM 20.0-b11

The IDE menus do not stay open after the left mouse button is released when the IDE is maximized. If the window size resize is reduced, the expected behavior is observed. Also, the mouse cursor position seems to be misreported (offset to the left and up). For example, in maximized mode clicking the help menu opens the help menu as expected (I am not releasing the left-mouse button to keep the menu open) but when I move the cursor straight down, the help menu disappears and the Window menu (next menu to the left appears). Moving the mouse further down cursor highlights items in the Window menu.

An initial search on Google, yielded this old and supposedly closed bug in Java: http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6434227

The behavior described in the bug report appears identical to the behavior that I am experiencing with the exception that the window has to be maximized to exhibit the problem.
Comment 1 Stanislav Aubrecht 2011-09-06 13:59:13 UTC

*** This bug has been marked as a duplicate of bug 198639 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo