Bug 199102 - Tomcat installed by installer cannot be registered
Tomcat installed by installer cannot be registered
Status: VERIFIED FIXED
Product: serverplugins
Classification: Unclassified
Component: Tomcat
7.0.1
PC Windows XP
: P1 (vote)
: 7.0.1
Assigned To: Petr Hejl
issues@serverplugins
: SPACE_IN_PATH
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-02 09:46 UTC by Jiri Skrivanek
Modified: 2011-06-06 08:17 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Stack trace from add server instance wizard. (6.28 KB, text/plain)
2011-06-02 09:46 UTC, Jiri Skrivanek
Details
sample test (2.11 KB, application/octet-stream)
2011-06-02 12:10 UTC, Petr Hejl
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Skrivanek 2011-06-02 09:46:20 UTC
Created attachment 108668 [details]
Stack trace from add server instance wizard.

If Tomcat 7.0.14 is installed by installer (either NetBeans installer or installer downloaded from http://mirror.atlanticmetro.net/apache/tomcat/tomcat-7/v7.0.14/bin/apache-tomcat-7.0.14.exe), it is not possible register its instance to IDE and attached exception is always thrown. If I download zip distribution of Tomcat 7.0.14, it works.
Comment 1 Petr Hejl 2011-06-02 12:10:00 UTC
Created attachment 108674 [details]
sample test

For some reason code inside tomcat is throwing exception. The code is simple so it might be something in Windows preventing access. Please try to run the test:

java -cp TestTomcat.jar;C:\path\to\tomcat\lib\catalina.jar;C:\path\to\tomcat\lib\tomcat-coyote.jar testtomcat.TestTomcat

I know how to resolve CNFE, but there might be something wrong anyway.

I'm not able to reproduce in XP.
Comment 2 Petr Hejl 2011-06-02 13:47:25 UTC
Fixed in web-main 8af5cd163906.

The root cause was usage of File.toURL().
Comment 3 Petr Hejl 2011-06-02 13:59:21 UTC
Transplanted to 701 25578f30e02a.
Comment 4 Quality Engineering 2011-06-03 18:16:51 UTC
Integrated into 'main-golden', will be available in build *201106031000* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/8af5cd163906
User: phejl@netbeans.org
Log: #199102 Tomcat installed by installer cannot be registered
Comment 5 Jiri Skrivanek 2011-06-06 08:17:58 UTC
Verified.
Product Version: NetBeans IDE 7.0.1 Dev (Build 201106052101)
Java: 1.7.0-ea; Java HotSpot(TM) Client VM 21.0-b14
System: Windows XP version 5.1 running on x86; Cp1250; en_US (nb)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo