Bug 199028 - Changing case on files/directories fails to commit properly with Subversion
Changing case on files/directories fails to commit properly with Subversion
Status: RESOLVED DUPLICATE of bug 153072
Product: versioncontrol
Classification: Unclassified
Component: Subversion
7.0
Macintosh All
: P3 (vote)
: TBD
Assigned To: Ondrej Vrabec
issues@versioncontrol
: PLATFORM, USABILITY
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-31 12:15 UTC by bcbud
Modified: 2011-10-06 10:31 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bcbud 2011-05-31 12:15:26 UTC
Product Version = NetBeans IDE 7.0 (Build 201104080000)
Operating System = Mac OS X version 10.6.6 running on x86_64
Java; VM; Vendor = 1.6.0_24
Runtime = Java HotSpot(TM) 64-Bit Server VM 19.1-b02-334

Recreate steps:

1) create project from Subversion repository (or create new and check in)
2) Change case of filename
	- ie: ThisIsMyFile.php -> Thisismyfile.php
3) Check subversion repos and you'll see two entries - the change in case doesn't record the change, but overwrites
4) Further attempts to update from repos will fail to pull new case changed file and corrupt commits

Incredibly frustrating bug that's been there since 7.0b1 - frequently causes our team to have to checkout and recreate project

Please fix!
Comment 1 Ondrej Vrabec 2011-05-31 13:12:15 UTC
AFAIK this never worked (not even in 6.9). Since java on Mac or Windows does not see a difference between ThisIsMyFile.php and ThisisMyFile.php, the IDE plugin cannot handle and resolve this situation. Maybe we'll find a work-around or at least detect the situation and notify user.
BTW, when you committed the second file (and after that had the two files in the repository) you must have realized that NetBeans still displays the deleted file in the Subversion View (after Subversion->Show Changes). So you must have suspected that something went wrong.
There's an easy workaround, go to commandline and commit the deleted file.
Comment 2 Ondrej Vrabec 2011-10-06 10:31:03 UTC
rename issues on Mac OS fixed in #153072 - see comment #13 and later

*** This bug has been marked as a duplicate of bug 153072 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo