Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 199027 - NullPointerException at org.netbeans.modules.javadoc.highlighting.Highlighting$HSImpl.moveNext
NullPointerException at org.netbeans.modules.javadoc.highlighting.Highlightin...
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Javadoc
7.1
All All
: P2 (vote)
: 7.2
Assigned To: Jan Becicka
issues@java
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-31 12:12 UTC by Jan Becicka
Modified: 2011-07-01 14:06 UTC (History)
8 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (4.68 KB, text/plain)
2011-05-31 12:12 UTC, Jan Becicka
Details
stacktrace (5.42 KB, text/plain)
2011-06-17 00:38 UTC, David Konecny
Details
stacktrace (6.27 KB, text/plain)
2011-06-17 08:47 UTC, Exceptions Reporter
Details
stacktrace (5.15 KB, text/plain)
2011-06-17 11:29 UTC, mps77
Details
stacktrace (3.06 KB, text/plain)
2011-06-24 10:52 UTC, muellermi
Details
stacktrace (2.18 KB, text/plain)
2011-06-24 10:55 UTC, muellermi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Becicka 2011-05-31 12:12:24 UTC
Build: NetBeans IDE Dev (Build 20110531-cfcd67a18957)
VM: Java HotSpot(TM) 64-Bit Server VM, 17.1-b03-307, Java(TM) SE Runtime Environment, 1.6.0_22-b04-307-9M3326
OS: Mac OS X

Stacktrace: 
java.lang.NullPointerException
   at org.netbeans.modules.javadoc.highlighting.Highlighting$HSImpl.moveNext(Highlighting.java:188)
   at org.netbeans.modules.editor.lib2.highlighting.CheckedHighlightsSequence.moveNext(CheckedHighlightsSequence.java:102)
   at org.netbeans.modules.editor.lib2.highlighting.ProxyHighlightsContainer$Sequence2Marks.moveNext(ProxyHighlightsContainer.java:432)
   at org.netbeans.modules.editor.lib2.highlighting.ProxyHighlightsContainer$ProxySeq.moveNext(ProxyHighlightsContainer.java:287)
   at org.netbeans.modules.editor.lib2.view.HighlightsViewFactory.updateHighlight(HighlightsViewFactory.java:186)
   at org.netbeans.modules.editor.lib2.view.HighlightsViewFactory.createView(HighlightsViewFactory.java:124)
Comment 1 Jan Becicka 2011-05-31 12:12:29 UTC
Created attachment 108620 [details]
stacktrace
Comment 2 Jan Becicka 2011-05-31 12:35:39 UTC
Changeset: http://hg.netbeans.org/jet-main/rev/3559b3206ebd
Author:    Jan Becicka <jbecicka@netbeans.org>
Date:      2011-05-31 14:33
Message:   
Issue #199027 - NullPointerException at org.netbeans.modules.javadoc.highlighting.Highlighting$HSImpl.moveNext
Comment 3 Quality Engineering 2011-06-01 13:29:24 UTC
Integrated into 'main-golden', will be available in build *201106010401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/3559b3206ebd
User: Jan Becicka <jbecicka@netbeans.org>
Log: Issue #199027 - NullPointerException at org.netbeans.modules.javadoc.highlighting.Highlighting$HSImpl.moveNext
Comment 4 _ gtzabari 2011-06-16 21:00:56 UTC
I am getting a NPE when hitting CTRL+Z to undo an editor operation. The exceptions keep on getting fired indefinitely, forcing me to close the entire IDE. The exception reporter says my issue is a duplicate of this bug report (which was closed) but I've reproduced it using:


Product Version: NetBeans IDE Dev (Build 201106130600)
Java: 1.6.0_25; Java HotSpot(TM) 64-Bit Server VM 20.0-b11
System: Windows 7 version 6.1 running on amd64; Cp1252; en_CA (nb)

So either this is a different bug or the problem is not resolved. Please take a look at recent exception reports for this issue.
Comment 5 David Konecny 2011-06-17 00:38:12 UTC
Created attachment 108941 [details]
stacktrace
Comment 6 Exceptions Reporter 2011-06-17 00:38:25 UTC
This bug already has 5 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=179095
Comment 7 David Konecny 2011-06-17 00:40:24 UTC
Same experience as gtzabari - I had to close the file without saving it and lose my changes which would classify it as P1. It happened only once so for now P2.
Comment 8 David Konecny 2011-06-17 00:44:14 UTC
I had to restart IDE because something got seriously broken by the NPE - selecting text stop displaying highlight etc. Consider some hotfix for 7.0.1. Although I have no idea how to reproduce.
Comment 9 Jan Becicka 2011-06-17 06:38:18 UTC
This issue does not affect 7.0. This is dev build issue.
Comment 10 Jan Becicka 2011-06-17 06:45:28 UTC
It is also possible, that the issue is in fact fixed, but your userdir contains some invalid items from not-yet-fixed build... Anyone able to reproduce it with clean userdir?
Comment 11 Exceptions Reporter 2011-06-17 08:47:13 UTC
Created attachment 108948 [details]
stacktrace
Comment 12 Jan Becicka 2011-06-17 09:19:58 UTC
Changeset: http://hg.netbeans.org/jet-main/rev/153f56cca253
Author:    Jan Becicka <jbecicka@netbeans.org>
Date:      2011-06-17 11:11
Message:   Improved logging. NPE thrown only once.
Issue #199027 - NullPointerException at org.netbeans.modules.javadoc.highlighting.Highlighting$HSImpl.moveNext
Comment 13 mps77 2011-06-17 11:29:13 UTC
Created attachment 108952 [details]
stacktrace
Comment 14 Exceptions Reporter 2011-06-17 22:41:18 UTC
This bug already has 10 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=179095
Comment 15 Quality Engineering 2011-06-18 15:10:39 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/153f56cca253
User: Jan Becicka <jbecicka@netbeans.org>
Log: Improved logging. NPE thrown only once.
Issue #199027 - NullPointerException at org.netbeans.modules.javadoc.highlighting.Highlighting$HSImpl.moveNext
Comment 16 _ gtzabari 2011-06-23 22:00:23 UTC
I reproduced this on a clean userdir. See my report here: http://statistics.netbeans.org/analytics/exception.do?id=516029
Comment 17 muellermi 2011-06-24 10:52:29 UTC
Created attachment 109091 [details]
stacktrace

Ctrl-z in editor
Comment 18 muellermi 2011-06-24 10:55:29 UTC
Created attachment 109092 [details]
stacktrace

un-comment in editor (via button)
Comment 19 _ gtzabari 2011-06-24 22:52:33 UTC
Good news! I found an easy way of reproducing the problem.

1. Place caret on top of variable in editor
2. Hit CTRL+R and rename the variable
3. Hit CTRL+Z. Exception will be thrown.

This is 100% reproducible for me.
Comment 20 Jan Becicka 2011-06-30 08:23:33 UTC
Changeset: http://hg.netbeans.org/jet-main/rev/b43452695c7b
Author:    Jan Becicka <jbecicka@netbeans.org>
Date:      2011-06-30 10:22
Message:   
Issue #199027 - NullPointerException at org.netbeans.modules.javadoc.highlighting.Highlighting$HSImpl.moveNext
Comment 21 Quality Engineering 2011-07-01 14:06:53 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/b43452695c7b
User: Jan Becicka <jbecicka@netbeans.org>
Log: Issue #199027 - NullPointerException at org.netbeans.modules.javadoc.highlighting.Highlighting$HSImpl.moveNext


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo