Bug 198918 - Throwing EQStuck breaks EQ on JDK 7
Throwing EQStuck breaks EQ on JDK 7
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: -- Other --
7.0
PC Linux
: P3 (vote)
: 7.0.1
Assigned To: Jesse Glick
issues@platform
701patch1-verified
:
: 200106 (view as bug list)
Depends on:
Blocks: 179597
  Show dependency treegraph
 
Reported: 2011-05-26 15:32 UTC by Jesse Glick
Modified: 2011-09-26 13:30 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Log file (66.36 KB, text/plain)
2011-05-26 15:32 UTC, Jesse Glick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2011-05-26 15:32:57 UTC
Created attachment 108527 [details]
Log file

At least I assume this is a JDK 7-specific issue since I have not seen it before starting to run recently with JDK 7. After Go to Symbol paused for a while (loading indices), an exception was thrown and then the GUI froze completely (no CPU activity).
Comment 1 Jesse Glick 2011-05-26 15:39:36 UTC
core-main #03878d292d5e
Comment 2 Quality Engineering 2011-05-27 11:53:24 UTC
Integrated into 'main-golden', will be available in build *201105270401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/03878d292d5e
User: Jesse Glick <jglick@netbeans.org>
Log: #198918: Throwing EQStuck breaks EQ on JDK 7
Comment 3 Tomas Danek 2011-06-10 12:59:05 UTC
any possible steps to reproduce for verification?
Comment 4 Jesse Glick 2011-06-10 18:29:30 UTC
Not easily I think. Could write a module w/ an action that calls Thread.sleep(9999), then run netbeans --open some/file from a shell while the IDE is frozen, and see if it recovers somehow. Bug #179597 would make the IDE recover immediately, at least on JDK 6.
Comment 5 Jesse Glick 2011-07-13 13:03:14 UTC
*** Bug 200106 has been marked as a duplicate of this bug. ***
Comment 6 Tomas Danek 2011-08-25 11:38:14 UTC
Verified, ide somehow recovers from UI freeze. Thanks.
Comment 7 Jesse Glick 2011-08-25 16:07:11 UTC
releases #338d1f6fcf4a
Comment 8 Quality Engineering 2011-08-26 04:27:06 UTC
Integrated into 'releases'
Changeset: http://hg.netbeans.org/releases/rev/338d1f6fcf4a
User: Jesse Glick <jglick@netbeans.org>
Log: #198918: Throwing EQStuck breaks EQ on JDK 7
(transplanted from 03878d292d5ec4690a82174c6730ebd98a29d8be)
Comment 9 Quality Engineering 2011-09-26 13:30:07 UTC
Integrated into 'releases'
Changeset: http://hg.netbeans.org/releases/rev/2588ebd586ea
User: Jesse Glick <jglick@netbeans.org>
Log: #198918: Throwing EQStuck breaks EQ on JDK 7
(transplanted from 03878d292d5ec4690a82174c6730ebd98a29d8be)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo