Bug 198712 - IDE hangs if source file is updated externally
IDE hangs if source file is updated externally
Status: RESOLVED DUPLICATE of bug 198141
Product: editor
Classification: Unclassified
Component: Painting & Printing
7.0
PC Solaris
: P2 (vote)
: 7.0
Assigned To: Miloslav Metelka
issues@editor
CR_7041176
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-18 16:22 UTC by Egor Ushakov
Modified: 2011-05-23 08:42 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (48.25 KB, text/plain)
2011-05-18 16:22 UTC, Egor Ushakov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Egor Ushakov 2011-05-18 16:22:57 UTC
Created attachment 108379 [details]
stacktrace

IDE hangs when source file is updated externally, see attached stacktrace
Comment 1 David Strupl 2011-05-20 08:31:26 UTC
Milo, can you please have a look? Seems like a deadlock between the ReadOnlyFilesHighlighting and document ...
Comment 2 Miloslav Metelka 2011-05-20 09:41:08 UTC
It's Doc <-> FS deadlock. I'll fix it today.
Comment 3 Miloslav Metelka 2011-05-23 08:42:48 UTC
I thought it's a new problem in the ReadOnlyFilesHighlighting but no, this is fixed already - dup of issue #198141.

*** This bug has been marked as a duplicate of bug 198141 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo