Bug 198087 - LowPerformance took 75577 ms.
LowPerformance took 75577 ms.
Status: RESOLVED WONTFIX
Product: javaee
Classification: Unclassified
Component: EJB Project
6.x
All All
: P3 (vote)
: TBD
Assigned To: David Konecny
issues@javaee
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-26 13:12 UTC by Exceptions Reporter
Modified: 2011-05-10 12:09 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (21.10 KB, application/nps)
2011-04-26 13:12 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2011-04-26 13:12:46 UTC
Build: NetBeans IDE 6.9.1 (Build 201011082200)
VM: Java HotSpot(TM) Client VM, 10.0-b22, Java(TM) SE Runtime Environment, 1.6.0_06-b02
OS: Windows XP
Maximum slowness yet reported was 75577 ms, average is 39760
Comment 1 Exceptions Reporter 2011-04-26 13:12:53 UTC
Created attachment 107945 [details]
nps snapshot
Comment 2 Martin Fousek 2011-04-28 09:02:48 UTC
From the last snapshots it seems that ActionStateUpdater.actionPerformed() invoke update of all node actions in EDT which is blocked by project save by its closing - saveProject() acquires writeAccess on the same mutex as is needed for reading by update of all actions. I will talk to t_h who contributed on this place and eventually reassign this issue.
Comment 3 Martin Fousek 2011-04-28 11:38:48 UTC
I'm reassigning the issue since it looks like Explorer API problem.
Comment 4 Jaroslav Tulach 2011-05-03 08:21:33 UTC
May I get an explanation why the issue is supposed to be problem in explorer? I see 65s wasted in EJB.
Comment 5 Martin Fousek 2011-05-03 09:52:14 UTC
Right, the delay seems to be rising in EJB, but actually it's coming between ExplorerActionsImpl.updateActions which leads to BaseActionProvider.isActionEnabled and ProjectManager.saveProject.

Especially now it looks to me as badly reassigned as well, sorry for that. :/ 
It is related to Projects. I took a look quickly into WEB, EJB projects and in both of them it could happen. Generally it can happen for any BaseActionProvider subtype.
Comment 6 Jaroslav Tulach 2011-05-04 07:25:37 UTC
Jesse, as designer of ActionProvider.isActionEnabled and other project code, shall advice you how to make the call non-blocking.
Comment 7 Jesse Glick 2011-05-05 21:33:25 UTC
According to the snapshot, 64 seconds is being spent in a single call to ClassLoader.getResourceAsStream - which would seem to indicate that the user's JVM is out of file handles, at max heap, swapped out, or otherwise pretty much busted. If so, there is nothing to be done in IDE code.
Comment 8 Martin Fousek 2011-05-10 12:09:52 UTC
Ok, totally agree. Closing as WONTFIX for now but jocke feel free to reopen if you would be able to reproduce it without exhausted resources. Thanks.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo