Bug 197985 - Remove checking for external changes
Remove checking for external changes
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Filesystems
7.0
PC Mac OS X
: P1 (vote)
: 7.1
Assigned To: Jaroslav Tulach
issues@platform
: PLAN
: 197964 (view as bug list)
Depends on:
Blocks: 26230
  Show dependency treegraph
 
Reported: 2011-04-22 05:34 UTC by Tomas Zezula
Modified: 2011-06-03 18:18 UTC (History)
3 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Zezula 2011-04-22 05:34:01 UTC
In the NB 7.0 the native file system listeners were integrated to remove a need to do fs refresh when IDE gained focus. But the refresh was returned back because only few features like parsing.api are using the native listeners. The native listeners should be used for all FOs and FS refresh should be removed.
Comment 1 Jaroslav Tulach 2011-04-22 06:56:46 UTC
Why?
Comment 2 Tomas Zezula 2011-04-22 07:09:13 UTC
When I return to the IDE the IDE does refresh which is IO expensive and I see progress Checking for external changes".
But if performance is not more the problem feel free to keep it as an enhancement.
Comment 3 Jesse Glick 2011-04-22 14:29:44 UTC
I think this is a duplicate of bug #197964, right?
Comment 4 Jaroslav Tulach 2011-04-26 04:50:06 UTC
*** Bug 197964 has been marked as a duplicate of this bug. ***
Comment 5 Jaroslav Tulach 2011-06-02 08:18:48 UTC
ergonomics#a3a413c6b780
Comment 6 Jaroslav Tulach 2011-06-02 08:29:09 UTC
Run with 
-J-Dorg.netbeans.modules.masterfs.watcher.Watcher.level=FINE
to see what is going on.
Comment 7 Quality Engineering 2011-06-03 18:18:35 UTC
Integrated into 'main-golden', will be available in build *201106031000* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/a3a413c6b780
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: #197985: Use native Notifier for regular listeners, not only for recursive ones


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo