Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 197964 - Native file notifications not available for non-recursive listeners
Native file notifications not available for non-recursive listeners
Status: RESOLVED DUPLICATE of bug 197985
Product: platform
Classification: Unclassified
Component: Filesystems
7.0
PC Linux
: P3 (vote)
: TBD
Assigned To: Jaroslav Tulach
issues@platform
: PERFORMANCE
Depends on:
Blocks: 190462
  Show dependency treegraph
 
Reported: 2011-04-21 19:32 UTC by Jesse Glick
Modified: 2011-04-26 04:50 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2011-04-21 19:32:55 UTC
FileUtil.addFileChangeListener(FileChangeListener, File) in 7.0 does not take advantage of native FS watchers. This means that such listeners force the IDE to poll for changes when the main window gets focus (i.e. MenuWarmUpTask), causing the same kind of performance problems as in NB 6.9. See bug #190462 comment #14.

(Not to be confused with bug #194147 - a fix of that would mean that all file events would be _queued_ until the main window is focused, whether they were detected by polling or native watchers.)
Comment 1 Jaroslav Tulach 2011-04-26 04:50:06 UTC
(In reply to comment #0)
> causing the same kind of performance problems as in NB 6.9. See bug #190462
> comment #14.

The same? Depends how you define identity! The problems are by magnitude smaller. Exact number depends on the amount of recursive vs. non-recursive files indeed.

*** This bug has been marked as a duplicate of bug 197985 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo