Bug 19794 - Add properties to display size
Add properties to display size
Status: RESOLVED FIXED
Product: utilities
Classification: Unclassified
Component: Image
6.x
All All
: P1 with 1 vote (vote)
: 6.x
Assigned To: Victor Vasilyev
issues@utilities
: NETFIX, UI
: 91215 162606 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-25 16:09 UTC by Rochelle Raccah
Modified: 2009-12-08 02:28 UTC (History)
4 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
Sample image for the future patch (7.12 KB, image/png)
2009-07-08 04:19 UTC, Michel Graciano
Details
Patch for the enhancement (2.72 KB, text/plain)
2009-07-08 04:21 UTC, Michel Graciano
Details
Patch with width and height in separated properties (3.60 KB, text/plain)
2009-07-08 04:40 UTC, Michel Graciano
Details
Properties to show image size #2 (7.29 KB, image/png)
2009-07-08 11:49 UTC, Michel Graciano
Details
3rd proposed patch (3.60 KB, patch)
2009-07-08 11:51 UTC, Michel Graciano
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Rochelle Raccah 2002-01-25 16:09:52 UTC
I mounted a jar filesystem and explored to some of the contained icons.  I was
hoping to see the size of the icon in the editor/viewer without unjarring and
opening in an external editor, but it seems that the image module doesn't
provide that.  It would be nice if that could be added, maybe just as read only
properties.
Comment 1 Marek Grummich 2002-07-22 09:03:58 UTC
Set target milestone to TBD
Comment 2 Marian Petras 2005-05-03 14:54:32 UTC
It would be a reasonable enhancement. Accepted.
Comment 3 Alexei Mokeev 2009-04-15 04:25:45 UTC
*** Issue 162606 has been marked as a duplicate of this issue. ***
Comment 4 Alexei Mokeev 2009-04-15 04:26:24 UTC
*** Issue 91215 has been marked as a duplicate of this issue. ***
Comment 5 Michel Graciano 2009-07-08 03:56:06 UTC
How could it be shown? Something like sizes at Matisse as [x,y] or should we have two properties, one for each property?
Comment 6 swpalmer 2009-07-08 04:08:04 UTC
There should be several read-only properties shown

width
height
coordinate last clicked on (to aid in calculating positions used in code)
color last clicked on (for selection to clipboard and pasting into code)

Also a way to easily measure distances in pixels would be nice.  All of these things could assist in integrating images 
into the rest of the UI that you are coding.
Comment 7 Michel Graciano 2009-07-08 04:19:43 UTC
Created attachment 84474 [details]
Sample image for the future patch
Comment 8 Michel Graciano 2009-07-08 04:21:43 UTC
Created attachment 84475 [details]
Patch for the enhancement
Comment 9 rdelaplante 2009-07-08 04:24:21 UTC
I like the idea of having separate width and height properties for clarity. Maybe even mention that the units are
pixels/px.  I also think the mouse-over coordinate and color would be helpful (hex and rgb?)  Thanks!
Comment 10 Michel Graciano 2009-07-08 04:24:28 UTC
I wish to track it by NetFIX program if you agree. The patch is already attached.

Regards
Comment 11 swpalmer 2009-07-08 04:30:07 UTC
I wanted not just a mouse-over coordinate and color (maybe a tool tip?), but fields that stuck to the values for the 
clicked on pixel - so I could then cut and paste from that field into the code. (fields that are changing as I move the 
mouse are no good for copying to the clipboard)
Show the colors in multiple formats (hex, and RGBA) - don't for get the alpha channel value if it is an image that has 
one.
Comment 12 swpalmer 2009-07-08 04:33:50 UTC
Name and Extension fields seem wasteful, since that will be in the "editor" tab , and it's also shown in two other places 
in the UI mockup shown in the property.png attachment.
Though the image format (which can be different from the extension) and MIME type.. would be useful.
Comment 13 Michel Graciano 2009-07-08 04:40:59 UTC
Created attachment 84476 [details]
Patch with width and height in separated properties
Comment 14 rdelaplante 2009-07-08 04:53:52 UTC
Added self to CC list
Comment 15 rdelaplante 2009-07-08 04:55:22 UTC
I think the patch meets the requirements of this ticket (width and height properties).  Anything else should probably be
separate RFE tickets. 
Comment 16 Michel Graciano 2009-07-08 04:56:08 UTC
Please, summarize the needed properties in an organized way. This issue is about size properties and we can track
another ones too.
About colors, take a look at this [1] plugin. It should help you.

Regards
[1] http://plugins.netbeans.org/PluginPortal/faces/PluginDetailPage.jsp?pluginid=1173
Comment 17 Michel Graciano 2009-07-08 05:02:05 UTC
I agree with Ryan, the patch is for this issue and for another properties, please file different issue(s) and CC me
please. The second patch I added 2 properties, one for each width and height even that I added pixel/px description at
details. I hope it will be integrated as soon as the patch could be reviewed.

Regards
Comment 18 rdelaplante 2009-07-08 05:05:13 UTC
Just a very minor detail.. I would use either "pixels" or "px" in the hint, but not both.  Preferably "pixels".  I have
no issues with you making this part of NetFIX, hopefully it that helps it get integrated sooner. 
Comment 19 Michel Graciano 2009-07-08 11:49:05 UTC
Created attachment 84490 [details]
Properties to show image size #2
Comment 20 Michel Graciano 2009-07-08 11:51:19 UTC
Created attachment 84491 [details]
3rd proposed patch
Comment 21 Michel Graciano 2009-07-08 11:52:36 UTC
Hopefully it will be the final patch. :-D
I fixed the hint to show just "pixels". Please, take a look at attached image to see the final result.

Regards
Comment 22 rdelaplante 2009-07-08 13:22:10 UTC
Perfect, thank you!!
Comment 23 Jiri Kovalsky 2009-07-13 15:24:25 UTC
Alexei, can somebody from your team please review latest Michel's patch and integrate it if no objections are found?
Thanks a lot!
Comment 24 Michel Graciano 2009-07-13 15:28:33 UTC
Probably license header should be updated too. Thanks
Comment 25 Jiri Kovalsky 2009-10-14 13:45:04 UTC
Alexei, any update on this please? Thanks!
Comment 26 Alexei Mokeev 2009-10-14 16:10:30 UTC
Jirka, hmichel,

I'm sorry, we did integrate this fix prior to 6.8 feature freeze. 

My apology,
-Alexei.
Comment 27 Jiri Kovalsky 2009-10-14 16:12:49 UTC
You mean "didn't" right?
Comment 28 Alexei Mokeev 2009-10-14 16:16:39 UTC
Yes, we didn't.
Comment 29 Michel Graciano 2009-10-14 16:26:24 UTC
I see. So, can we do this after FCS?
Comment 30 Alexei Mokeev 2009-10-14 16:29:09 UTC
Yes. As soon as trunk will be opened for post 6.8 changes.
Comment 31 Alexei Mokeev 2009-12-03 03:16:03 UTC
Good candidate
Comment 32 Jiri Kovalsky 2009-12-03 08:56:26 UTC
So, the trunk is now open, can we please integrate this patch? Thanks a lot!
Comment 33 Victor Vasilyev 2009-12-07 07:50:44 UTC
Fixed in the main trunk
http://hg.netbeans.org/main/rev/9db626c06a7d

The issue#19794#3.patch is applied.
Comment 34 Jiri Kovalsky 2009-12-07 08:01:46 UTC
Thanks a lot Victor and especially Michel for your patch!
Comment 35 Quality Engineering 2009-12-08 02:28:26 UTC
Integrated into 'main-golden', will be available in build *200912080200* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/9db626c06a7d
User: Victor G. Vasilyev <vvg@netbeans.org>
Log: #19794 -  Add properties to display size. Proposed NETFIX issue#19794#3.patch is applied.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo