Bug 197915 - Stack-traces are not being converted to links
Stack-traces are not being converted to links
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Output Window
7.0
PC Windows 7 x64
: P3 (vote)
: 7.0.1
Assigned To: Martin Entlicher
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-20 18:39 UTC by _ gtzabari
Modified: 2011-05-25 10:37 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ gtzabari 2011-04-20 18:39:17 UTC
Netbeans 7.0 RC2
JDK 1.6 update 24

I am seeing pretty serious regressions involving stack-traces not being converted to links in the output window.

1. Load a Maven Java Application project
2. Compile class with errors
3. I get this output but only the last line shows up as a link:

---------------------------------
cd C:\Users\Gili\Documents\foo\health\client; "JAVA_HOME=C:\\Program Files\\Java\\jdk1.6.0_24" "\"C:\\Program Files\\NetBeans 7.0 RC2\\java\\maven\\bin\\mvn.bat\"" install
Scanning for projects...
                                                                        
------------------------------------------------------------------------
Building foo.health.client 1.0-SNAPSHOT
------------------------------------------------------------------------

[resources:resources]
Using 'UTF-8' encoding to copy filtered resources.
Copying 11 resources

[compiler:compile]
Compiling 1 source file to C:\Users\Gili\Documents\foo\health\client\target\classes
------------------------------------------------------------------------
BUILD FAILURE
------------------------------------------------------------------------
Total time: 1.054s
Finished at: Wed Apr 20 14:36:40 EDT 2011
Final Memory: 7M/184M
------------------------------------------------------------------------
Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:2.0.2:compile (default-compile) on project foo.client: Compilation failure: Compilation failure:
C:\Users\Gili\Documents\foo\health\client\src\main\java\com\foo\health\client\MainPanel.java:[41,6] background is not public in java.awt.Component; cannot be accessed from outside package

C:\Users\Gili\Documents\foo\health\client\src\main\java\com\foo\health\client\MainPanel.java:[41,2] cannot find symbol
symbol  : method add(java.awt.Color,java.lang.Integer)
location: class com.foo.health.client.MainPanel

C:\Users\Gili\Documents\foo\health\client\src\main\java\com\foo\health\client\MainPanel.java:[43,2] background is not public in java.awt.Component; cannot be accessed from outside package

C:\Users\Gili\Documents\foo\health\client\src\main\java\com\foo\health\client\MainPanel.java:[43,12] cannot find symbol
symbol  : method setIcon(javax.swing.ImageIcon)
location: class java.awt.Color

C:\Users\Gili\Documents\foo\health\client\src\main\java\com\foo\health\client\MainPanel.java:[44,2] background is not public in java.awt.Component; cannot be accessed from outside package

C:\Users\Gili\Documents\foo\health\client\src\main\java\com\foo\health\client\MainPanel.java:[44,12] cannot find symbol
symbol  : method setSize(int,int)
location: class java.awt.Color
-> [Help 1]

To see the full stack trace of the errors, re-run Maven with the -e switch.
Re-run Maven using the -X switch to enable full debug logging.

For more information about the errors and possible solutions, please read the following articles:
[Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoFailureException
---------------------------------
Comment 1 _ gtzabari 2011-04-20 18:40:45 UTC
A similar problem is when the output window contains stack-traces such as this:

[exec:exec]
Exception in thread "AWT-EventQueue-0" java.lang.IllegalArgumentException: input == null!
	at javax.imageio.ImageIO.read(ImageIO.java:1362)
	at com.foo.health.client.MainPanel.<init>(MainPanel.java:35)
	at com.foo.health.client.Main$1.run(Main.java:52)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:642)
	at java.awt.EventQueue.access$000(EventQueue.java:85)
	at java.awt.EventQueue$1.run(EventQueue.java:603)
	at java.awt.EventQueue$1.run(EventQueue.java:601)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:87)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:612)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)
------------------------------------------------------------------------
BUILD SUCCESS
------------------------------------------------------------------------
Total time: 2.585s
Finished at: Wed Apr 20 14:39:04 EDT 2011
Final Memory: 7M/184M
------------------------------------------------------------------------

In the line "com.foo.health.client.MainPanel.<init>(MainPanel.java:35)" the letters "com." are not underlined but the rest of the line is. I am expecting the entire line to be highlighted.
Comment 2 _ gtzabari 2011-04-26 20:27:32 UTC
My guess is that this is related to Maven 3.0. Netbeans 6.9.1 suffers from the same problem if Maven 3 is used.
Comment 3 Marian Mirilovic 2011-05-02 09:00:38 UTC
Thanks for report, we already know about this regression - plan to fix it in the first patch.

*** This bug has been marked as a duplicate of bug 197381 ***
Comment 4 Jesse Glick 2011-05-05 17:44:02 UTC
(In reply to comment #0)
> C:\Users\Gili\Documents\foo\health\client\src\main\java\com\foo\health\client\MainPanel.java:[41,2]
> cannot find symbol
> symbol  : method add(java.awt.Color,java.lang.Integer)
> location: class com.foo.health.client.MainPanel

This looks different from bug #197381, which was about working around a bug in the Maven compiler plugin which omits the drive letter in its output; in the sample printed above, the Maven output looks OK and NB should be hyperlinking it (assuming the named file really exists). Check whether it is really fixed in a post-7.0 development build, otherwise file a fresh bug in projects/Maven with steps to reproduce from scratch. Anyway the summary here is about "stack traces" and the above is not a stack trace line.

(In reply to comment #1)
> In the line "com.foo.health.client.MainPanel.<init>(MainPanel.java:35)" the
> letters "com." are not underlined but the rest of the line is. I am expecting
> the entire line to be highlighted.

I have observed this too. I believe it is a bug in the Output Window relating to the display of TAB characters. Try turning line wrap mode on or off to see if that affects it.
Comment 5 _ gtzabari 2011-05-09 18:02:23 UTC
> Try turning line wrap mode on or off to see if that affects it.

I just checked: toggling line-wrap makes no difference.
Comment 6 Martin Entlicher 2011-05-13 20:05:56 UTC
I've verified that it's a bug of Output Window that occur when tabs form a part of the link.
Comment 7 Martin Entlicher 2011-05-24 15:17:59 UTC
Fixed by changeset:   194549:c288e9c3aeb7
http://hg.netbeans.org/main/rev/c288e9c3aeb7
Comment 8 Martin Entlicher 2011-05-24 15:29:16 UTC
Pushed to release701 as changeset:   199106:309aa7321bbd
Comment 9 Quality Engineering 2011-05-25 10:37:32 UTC
Integrated into 'main-golden', will be available in build *201105250400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/c288e9c3aeb7
User: mentlicher@netbeans.org
Log: #197915 Do not translate tabs to spaces for links. It breaks character indexes.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo