Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 197654 - Switching code folding off and on again - have to reopen files to make it work
Switching code folding off and on again - have to reopen files to make it work
Status: VERIFIED FIXED
Product: editor
Classification: Unclassified
Component: Code folding
6.x
All All
: P3 (vote)
: 7.0
Assigned To: Jan Lahoda
issues@editor
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-12 10:01 UTC by Vladimir Riha
Modified: 2011-05-03 06:59 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Riha 2011-04-12 10:01:30 UTC
If I turn off code folding, then the place (column) with marks +/- correctly disappears and the code is shifted to the left. When I turn it on again, the text is shifted to right but there are no folding marks, keyboard shortcuts don't work. When I reopen the file again, all folding marks are there as they should be and everything is working.


Product Version: NetBeans IDE 7.0 (Build 201104080000)
Java: 1.6.0_25; Java HotSpot(TM) Client VM 20.0-b11
System: Windows XP version 5.1 running on x86; Cp1250; cs_CZ (nb)
Comment 1 Vladimir Riha 2011-04-12 10:05:03 UTC
Tested in html and java files...
Comment 2 Marian Mirilovic 2011-04-12 11:19:22 UTC
100% reproducible ... BTW: it doesn't work in NB 6.9.1 either
Comment 3 Jan Lahoda 2011-04-28 15:39:25 UTC
I believe this does not work (for Java) since at least 6.0. Any way to force reparse is sufficient - typing in the editor, switching tabs, etc. Keeping in editor/codefolding only because this will require fixes both in Java and CSL.
Comment 4 Jan Lahoda 2011-04-30 14:44:25 UTC
(BTW, I tried C++ and it appears to be OK.)
http://hg.netbeans.org/main-silver?cmd=changeset;node=58e3365f8031
Comment 5 Quality Engineering 2011-05-02 16:26:23 UTC
Integrated into 'main-golden', will be available in build *201105021133* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/58e3365f8031
User: Jan Lahoda <jlahoda@netbeans.org>
Log: #197654: when code folding is enabled, re-plan the code folding parser task so that the folds are computed and shown again.
Comment 6 Vladimir Riha 2011-05-03 06:59:23 UTC
verified

Product Version: NetBeans IDE Dev (Build 201105030000)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo