Bug 197652 - Frozen IDE during work with Maven EE app.
Frozen IDE during work with Maven EE app.
Status: RESOLVED DUPLICATE of bug 197510
Product: projects
Classification: Unclassified
Component: Maven
7.0
PC Mac OS X
: P2 (vote)
: TBD
Assigned To: Jesse Glick
issues@projects
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-12 09:40 UTC by Tomas Danek
Modified: 2011-04-14 16:51 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
threaddump (31.61 KB, text/plain)
2011-04-12 09:40 UTC, Tomas Danek
Details
threaddump2 (40.15 KB, application/octet-stream)
2011-04-14 15:07 UTC, Tomas Danek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Danek 2011-04-12 09:40:55 UTC
Created attachment 107671 [details]
threaddump

NetBeans 7.0 FCS Candidate (20110408)
------------------------
- created maven ee app, clean and build, tried to create session bean, ide froze. Thread dump attached.

Please evaluate ASAP for potential stopper.
Comment 1 Jesse Glick 2011-04-12 13:24:39 UTC
Should already be fixed in dev builds. Whether this is a 7.0 stopper is for someone else to decide, based on how reproducible the issue is. It is not a deadlock because the IDE should recover once indices are created, though this may take several minutes.

I think the freeze will only happen if you have not yet indexed your Maven repositories, which would normally have already happened during daily use. The code in 7.0 is supposed to also be skipping repositories which are not yet indexed; perhaps some repo is marked as indexed but the index is out of date so an attempt to query it triggers a reindex? loadIndexingContext and getLoaded use slightly different logic to check if a repo is indexed, though it seems that presence in the "loaded" list should imply that loadIndexingContext would not call indexLoadedRepo, short of a race condition. (I think Tonda introduced getLoaded in bug #191313, so adding him to CC in case he has any insight on that.)

*** This bug has been marked as a duplicate of bug 197510 ***
Comment 2 Tomas Danek 2011-04-14 15:03:08 UTC
could you please check new threaddump2, if i am dealing with still the same thing? It seems like it happend to me again, yes, during indexing local repo, but was not freeze IMHO, since progress got stuck on 92% and IDE did not recover even after ~5 minutes. feel free to close again then.
Comment 3 Tomas Danek 2011-04-14 15:07:38 UTC
Created attachment 107754 [details]
threaddump2
Comment 4 Tomas Danek 2011-04-14 15:10:28 UTC
FYI:
Product Version: NetBeans IDE 7.0 (Build 201104080000)
Java: 1.6.0_25; Java HotSpot(TM) 64-Bit Server VM 20.0-b11
System: Linux version 2.6.35-28-generic running on amd64; ANSI_X3.4-1968; en_US (nb)
Userdir: /home/tomas/.netbeans/7.0
Comment 5 Jesse Glick 2011-04-14 16:51:56 UTC
Yes, it is the same:

"org.netbeans.modules.maven.execute.MavenCommandLineExecutor" daemon prio=10 tid=0x00007fd2fda08800 nid=0x1c23 in Object.wait() [0x00007fd2e5edb000]
...
	at org.netbeans.modules.maven.indexer.api.RepositoryQueries.findBySHA1(RepositoryQueries.java:209)
	at org.netbeans.modules.maven.classpath.EndorsedClassPathImpl.getResources(EndorsedClassPathImpl.java:113)
...

(Regarding "freeze" vs. "deadlock": your thread dump shows the IDE in two active HTTP downloads; of course it is possible your network or the server was dead.)

*** This bug has been marked as a duplicate of bug 197510 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo